*** are not supported at this language level 异常解决
*** are not supported at this language level 异常解决
为了美好的明天 发表于5个月前
*** are not supported at this language level 异常解决
  • 发表于 5个月前
  • 阅读 11
  • 收藏 0
  • 点赞 0
  • 评论 0

新睿云服务器60天免费使用,快来体验!>>>   

IDEA 的  ****are not supported at this language level  都可以通过这个解决

比如:

for-each loops are not supported at this language level

这个异常是 设置语言等级和使用的JDK版本不符,新的JDK语法老的语言等级不支持

解决办法:

在您的模块或项目上点击F4,或者点击File->project structure ,进入project structure然后转到名为“Project”的列表中的第一个菜单项

project language level系统默认的是1.3 改成最新或相应版本就OK了,以后所有新建的的Module 的language level都会是改后的等级。

对于已经存在的可以在这里改:

标签: idea language level
  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 11
博文 311
码字总数 114272
×
为了美好的明天
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: