文档章节

Eclipse环境搭建全集(个人使用的环境,Eclipse+SVN+Maven+JbossTo...

Credo-Zhao
 Credo-Zhao
发布于 2012/07/11 23:53
字数 1504
阅读 3624
收藏 6

1.JDK的配置
去官网下载JDK,需要注意的是JDK 32位,Eclipse也必须是32位.64位JDK对应Eclipse64位.
1.安装JDK,安装过程中最好自定义安装目录等信息,如我们选择安装目录为E:\software\Java\jdk1.6.0_34 .
2.安装完成后,我的电脑点击属性,选择高级选项卡点击环境变量.
3.在系统变量中,设置3项属性,JAVA_HOME,PATH,CLASSPATH(大小写不敏感),存在则编辑,不存在则新建.
3.JAVA_HOME是JDK安装路径,如:E:\software\Java\jdk1.6.0_34,Java工具等都会依赖这个变量.
Path使得系统可以在任何路径下识别java命令,设为(冒号里面的):
;%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin;
CLASSPATH为java加载类(classorlib)路径,只有类在classpath中,java命令才能识别,设为(冒号里面的):
;%JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar;
%JAVA_HOME%就是引用前面指定的JAVA_HOME; 
4.cmd键入命令“java -version”,“java”,“javac”出现对应信息说明环境变量配置成功;

 

2.Eclipse插件的选择,安装

进入Eclipse-->Help--->Install New Sofeware-->输入网站,这个是Eclipse在线安装插件的方法.

插件里,SVN是必装的,maven也是必装的.我还选择了Jboss-tools插件.其强大的JSF提示,properties文件的读取,是很不错的,我找半天也没找到替代品.我的Eclipse版本是4.2.装这个三个插件通过测试.

SVN具体安装:

SVN:首先你需要安装SVN.下载地址有:
http://subclipse.tigris.org/update_1.6.x
http://subclipse.tigris.org/update_1.8.x (支持Subversion 1.7.x)
注意选择好版本,我就选错了版本苦恼了半天,因为的文档里是1.6.x的链接地址,所以SVN一直报个版本的错误.搞的我莫名其妙.后来在 http://www.oschina.net/p/subclipse看到第二个地址才弄对.

 

 

Maven3具体安装:

然后就是maven插件的的安装:

链接地址:http://m2eclipse.sonatype.org/sites/m2e

1.安装maven之前,要先安装jdk及配置JAVA_HOME环境变量。JDK1.4以上。

2.下载maven3,最新版本是Maven3.0.3 ,下载地址:http://maven.apache.org/download.html
下载apache-maven-3.0.3-bin.zip文件后,并解压到D:\tools\apache-maven-3.0.3

3.配置maven3的环境变量,先配置M2_HOME的环境变量,值为"D:\tools\apache-maven-3.0.3",(设置环境变量,设置到系统环境变量中去,不要设置在上面的用户环境变量,因为系统环境变量权限更大)如下图所示:

再配置path环境变量,在path值的末尾添加"%M2_HOME%\bin",(设置环境变量,设置到系统环境变量中去,不要设置在上面的用户环境变量,因为系统环境变量权限更大)如下图所示;


打开cmd命令窗口,执行"mvn -version",会输出下面的内容,表示安装成功。 

其后步骤:

如果你已经成功安装了这个插件,当你打开Window → Preferences...的时候,你应该能够在一个选项列表中看到一个Maven选项

安装好m2eclipse插件后,要作两个设置

   a) 禁用Download repository index updates on startup(即取消这个选项的勾选,第三个第四个可以点上),如下图


另外记得设置maven,使用你的安装目录.


=========================

安装Maven后每次启动出现警告信息:

Eclipse is running in a JRE, but a JDK is required
Some Maven plugins may not work when importing projects or updating source folders.

分两步解决问题:

1. 检查Eclipse正在使用的JRE

‘Window’ -> ‘Preferences’ -> ‘Java’ -> ‘Installed JREs’ 确定正在使用JDK而非JRE.

2. 配置Eclipse.ini

检查Eclipse配置文件, 增加/编辑以下代码

-vm    
C:\Progra~2\Java\jdk1.6.0_16\jre\bin\javaw

注意事项:

1. 第一行参数名称, 第二行为值, 不能写到同一行中

2. 关于第二行的值, 因为不允许出现空格, 所以使用Progra~1或2 替代”Program Files (x86)”.
如果在Program Files下, 请使用Progra~1, 如果在x86下, 则使用Progra~2.所以我不推荐java装到默认目录,推荐装到D,E什么地方.

如:

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
E:/software/Java/jdk1.6.0_34/jre/bin/javaw
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xms40m
-Xmx512m

3. 在文件中的位置, 不能放到最后(不能在-vmargs之后), 不放心的直接放到文件最前, 如:

4.注意自己的JDK版本是否和上述一致,不一致请修改

3. 重启Eclipse, 警告不再出现.

================补充==========================

在Eclipse中建立项目,我建立 webapp-javaee6 / 1.5这个.

在上述都安装OK后,还需要设置一些东西.原先我的Eclipse的maven就出现一些问题.现在如下:

勾选如下进行更新模板



 

3.JBOSSTOOLS插件的安装:

我个人是非常喜欢这个插件的.页面代码提示,JSF的前台连接后台manageBean的支持.对properties文件的完美支持.都是我非常喜欢的,曾经找到很多替代品,但发现都不如这个好用.除了SVN和maven,这个也是我Eclipse的必装插件.

我刚刚也在OSCHINA上找到一个编辑properties文件的插件,http://www.oschina.net/p/properties+editor 不过试用了下感觉还是没jbosstools支持好,果断删掉Eclipse重新下载了JbossTools

JbossTools的下载地址为: http://download.jboss.org/jbosstools/updates/nightly/trunk/ 

OSCHINA也有介绍:http://www.oschina.net/p/jbosstools

安装后,出现如下图的时候,按图进行选择,只选如图第二个,然后进第二个里进行唰选:

下面是第二个里选一些:

需要说明的是 JBOSS Central Community是非常巨大的一个东西,足足85MB.最好别装.

 皮肤插件

https://raw.github.com/guari/eclipse-ui-theme/master/com.github.eclipseuitheme.themes.updatesite

StartExplorer GITHUB地址

https://github.com/zhaoqian/startexplorer

Eclipse下编辑properties文件的插件,用来写国际化程序非常方便,自动保存为ASCII码。日本人开发的,所以介绍网页全是日文。

UPDATE地址:http://propedit.sourceforge.jp/eclipse/updates



© 著作权归作者所有

共有 人打赏支持
上一篇: eclipse设置和优化
下一篇: angular 升级问题
Credo-Zhao
粉丝 310
博文 161
码字总数 241124
作品 0
朝阳
技术主管
私信 提问
加载中

评论(3)

Credo-Zhao
Credo-Zhao
https://raw.github.com/guari/eclipse-ui-theme/master/com.github.eclipseuitheme.themes.updatesite
Credo-Zhao
Credo-Zhao
https://github.com/guari/eclipse-ui-theme 扁平化皮肤
Credo-Zhao
Credo-Zhao
StartExplorer
Java之OpenCV安装与使用(入门)-yellowcong

这个例子,简单的讲解了Openvc的安装环境的搭建,以及第一个测试的小例子。 安装包下载 安装opencv 1、选择安装地址 2、一顿解压 解压完成后,可以看到opencv的文件文件,这样就ko了 Eclips...

yelllowcong
01/06
0
0
[Android开发实践]搭建本地API服务器与HTTP请求调用

目的 在Android开发下,可以实现app对特定API服务器进行接口请求。 场景 现在很多项目都是基于C/S架构,所以在个人开发过程需要搭建类似的开发测试环境。列举一下本次的环境: 开发环境:Win...

暗夜在火星
2014/06/28
0
0
请问 如何在在eclipse中搭建python3 + opencv的环境

准备搭建python3+opencv3 环境, 搞了两天, 一直不能在eclipse中实现 import cv2的调用. 请大家帮助一下: 现在情况是: 1. eclipse + python3的已经搭建好了, 用输出"print hello"验证 2. 使用...

河马河马
2015/07/16
597
1
python资料全集

python: 微信公众号开发小记——2.80端口上的服务 python: 微信公众号开发小记——3.接入三方登录 使用python编写一个壁纸网站的简单爬虫 python: python List 用法 Python 中各个时间复杂度...

d_watson
2016/04/15
175
0
Windows系统下Eclipse上搭建Python开发环境

Windows系统下Eclipse上搭建Python开发环境 在Eclipse上安装和搭建Python开发环境需要以下五步完成: (第一步)下载最新的Eclipse安装包。 我是基于Python版本python-3.6.4。python-3.6.4要...

zhangphil
01/03
0
0

没有更多内容

加载失败,请刷新页面

加载更多

开源 java CMS - FreeCMS2.8会员我的评论

项目地址:http://www.freeteam.cn/ 我的评论 从左侧管理菜单点击我的评论进入。在这里可以查看当前登录会员的所有评论记录。 删除评论 选择评论然后点击删除按钮可以完成删除操作。 为了防止...

freeteam
11分钟前
1
0
Eureka Server启用 https服务指北

文章共 591字,阅读大约需要 2分钟 ! 概 述 在我的前文《Eureka Server 开启Spring Security Basic认证》中已经给 Eureka Server 开启了最基本的鉴权措施,本文则让 HTTPS加持于 Eureka Ser...

CodeSheep
49分钟前
13
0
OSChina 周二乱弹 —— 其实我在地板也睡不着

Osc乱弹歌单(2018)请戳(这里) 【今日歌曲】 @witt-z :分享歌词: 阴天 在不开灯的房间,当所有思绪都一点一点沉淀。 分享莫文蔚的单曲《阴天》: 《阴天》- 莫文蔚 手机党少年们想听歌,...

小小编辑
今天
460
7
微服务分布式事务实现

https://www.processon.com/view/link/5b2144d7e4b001a14d3d2d30

WALK_MAN
今天
3
0
《大漠烟尘》读书笔记及读后感文章3700字

《大漠烟尘》读书笔记及读后感文章3700字: 在这个浮躁的社会里,你有多久没有好好读完一本书了? 我们总觉得自己和别人不一样,所以当看到别人身上的问题时,很少有“反求诸己”,反思自己。...

原创小博客
今天
5
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部