CentOS 6.5部署Apache+SVN
CentOS 6.5部署Apache+SVN
天下杰论 发表于3年前
CentOS 6.5部署Apache+SVN
  • 发表于 3年前
  • 阅读 429
  • 收藏 6
  • 点赞 0
  • 评论 0

腾讯云 十分钟定制你的第一个小程序>>>   

说明:运维朋友都知道,常常会配合开发人员搭建一些他们需要的环境,来提高开发工作效率,他们每天面对的无非就是代码,所以代码的可用性和管理性对 开发至关重要的,开发公司每接到一个项目就是一个团队来开发,这样多人同时对一些代码进行修改,会面临一些问题,比如:误删除,对同一文件修改发生冲突, 对某些人不让有所有权限,都会造成工作效率降低,要想解决这些问题就需要有一个专业的版本管理系统来集中管理这些代码,这样的版本管理系统很多,我们这次 使用的是SVN(subversion),是cvs接班人,是现在开源软件使用最多的版本管理软件,不多说了,开始搭建一个属于自己的版本控制系统吧。

SVN服务器有2种运行方式:独立服务器和借助apache运行(Web/DAV)。

1、安装依赖包


[root@localhost ~]# yum install gcc gcc-++ make pcre-develzlib-devel -y

[root@localhost ~]# tar zxvf apr-1.4.6.tar.gz
[root@localhost ~]# cd apr-1.4.6
[root@localhost apr-1.4.6]# ./configure --prefix=/usr/local/apr
[root@localhost ~]# make && make install


[root@localhost ~]# tar zxvf apr-util-1.4.1.tar.gz
[root@localhost ~]# cd apr-util-1.4.1
[root@localhostapr-util-1.4.1]# ./configure --prefix=/usr/local/apr-util--with-apr=/usr/local/apr
[root@localhost ~]# make && make install

2、安装Apache
下载:http://mirrors.cnnic.cn/apache/httpd/
[root@localhost ~]# tar zxvf httpd-2.4.7.tar.gz
[root@localhost ~]# cd httpd-2.4.7
[root@localhost httpd-2.4.7]#./configure --prefix=/usr/local/apache --enable-dav --enable-so--enable-rewrite --enable-maintainer-mode --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util/
[root@localhost ~]# cp /usr/local/apache/bin/apachectl /etc/init.d/httpd
[root@localhost ~]# sed -i's/#ServerName.*/ServerName localhost/' /usr/local/apache/conf/httpd.conf

3、安装SVN
SVN需要需要SQLite数据库支持,我们先安装SQLite
下载:http://www.sqlite.org/download.html
1234 [root@localhost ~]# tar zxvf sqlite-autoconf-3080200.tar.gz
[root@localhost ~]# cd sqlite-autoconf-3080200
[root@localhostsqlite-autoconf-3080200]# ./configure
[root@localhostsqlite-autoconf-3080200]# make && make install

 #安装SVN
下载:http://subversion.apache.org/download
[root@localhost ~]# tar zxvf subversion-1.8.5.tar.gz
[root@localhost ~]# cd subversion-1.8.5
[root@localhostsubversion-1.8.5]# ./configure --prefix=/usr/local/subversion--with-apxs=/usr/local/apache/bin/apxs --with-apr=/usr/local/apr--with-apr-util=/usr/local/apr-util/
[root@localhostsubversion-1.8.5]# make && make install

./confiure报错:这是因为apsx文件没有指定perl执行程序位置
apache/bin/apxs:/usr/local/perl: bad interpreter: No such file or directory
configure: error: no - APXSrefers to an old version of Apache
解决:[root@localhost ~]# vi /usr/local/apache/bin/apxs
#!/replace/with/path/to/perl/interpreter–w  #将第一行修改为#!/usr/bin/perl –w即可
  #添加环境变量

[root@localhost ~]# echo "PATH=$PATH/:/usr/local/subversion/bin" >> /etc/profile
[root@localhost ~]# source /etc/profile
[root@localhost ~]# svnserve –version  #显示版本信息表示正常

共有 人打赏支持
粉丝 54
博文 392
码字总数 23359
×
天下杰论
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: