文档章节

eclipse 运行 maven install的时候,出现这个错误:ERROR: Unable

ZhakyMing
 ZhakyMing
发布于 2015/09/13 16:21
字数 257
阅读 8
收藏 0

在使用eclipse 运行 maven install的时候,出现错误:

我使用的Eclipse的是 :

Eclipse Java EE IDE for Web Developers.
Version: Kepler Release
Build id: 20130614-0229

Mavenapache-maven-2.2.1

异常情景:

在使用eclipse 运行 maven install的时候,出现这个错误: 

ERROR: Unable to locate the Javac Compiler in:,  C:\Program Files (x86)\Java\jre6\..\lib\tools.jar,Please ensure you are using JDK 1.4 or above and,not a JRE (the com.sun.tools.javac.Main class is required).,In most cases you can change the location of your Java ,installation by setting the JAVA_HOME environment variable.

2.1:打开 :Window -> Preferences -> Java -> installed JREs -> 

选择你正在使用的JRE(应该是一个在jdk。例:C:\Program Files\Java\jdk1.6.0_43 )

2.2  、接着,点击“Edit”,进入下一个画面:选择添加 C:\Program Files\Java\jdk1.6.0_43\lib\tools.jar ,点击 Finish

2.3、接下来,打开 Window -> Preferences -> Java -> installed JREs -> Execution Enviroments ->

进入画面:选择JavaSE-1.6和相匹配的 jre