android 中adt ,sdk,api的对应关系
android 中adt ,sdk,api的对应关系
happyliferao 发表于2年前
android 中adt ,sdk,api的对应关系
  • 发表于 2年前
  • 阅读 3607
  • 收藏 15
  • 点赞 0
  • 评论 1
ADT(Android Development Tools):
目前Android开发所用的开发工具是Eclipse,在Eclipse编译IDE环境中,安装ADT,为Android开发提供开发工具
的升级或者变更,简单理解为在Eclipse下开发工具的升级下载工具。adt只是一个eclipse的插件, 里面可以设置sdk路径    
SDK(Software Development Kit):
一般是一些被软件工程师用于为特定的软件包、软件框架、硬件平台、操作系统等建立应用软件的开发工具的集合。
在Android中,他为开发者提供了库文件以及其他开发所用到的工具。简单理解为开发工具包集合,
是整体开发中所用到的工具包,如果你不用Eclipse作为你的开发工具,你就不需要下载ADT,只下载SDK即可开发。
SDK可以自己编译,在linux环境下通过make命令进行,耗时比较长,需要有耐心哦亲。。。
然后我们可以把自己编译的SDK通过ADT导入eclipse。在此基础上可以对源码包进行修改,
比如修改android system/app/phone.apk中的源码,然后再次调用make命令,
就可以产生新的system.image文件,此文件是镜像文件。

---------- 手机ROM中包含两个基本的image,一个是boot.image,这个image中主要是kernel和文件系统/目录 下的一些东西。kernel我就不说了,/目录下主要是init和相关的配置文件 system.image是android系统的userpace的核心,包括/system/bin,system/lib,system/app下的一些东西 

Android平台与SDK Tools版本、ADT版本的对应关系

Android平台      SDK Tools的版本    ADT版本
Android 2.2               R7                     ADT-0.9.9
Android 2.3               R8                     ADT-8.0.1
Android 3.0 预览版     R9                     ADT-9.0.0
Android 3.0               R10                   ADT-10.0.0
Android 3.1               R11                   ADT-11.0.0

Android 3.2              R12                    ADT-12.0.0

Android 4.0              R14                    ADT-14.0.0


SDK 平台版本,以及API版本

Android平台           API 级别
Android 2.0.11              API6
Android 2.1-update1        API7
Android 2.2                   API8
Android 2.3                   API9
Android 2.3.3                 API10 
Android 3.0                   API11
Android 3.1                   API12

Android 3.2                   API13

Android 4.0                   API14


android 的开发工具下载地址:http://www.cnblogs.com/bjzhanghao/archive/2012/11/14/android-platform-sdk-download-mirror.html


Android的SDK与ADT不匹配问题

ubuntn更新SDK后,在Eclipse preference里指向android-sdk-windows时。 出现 : This Android SDK requires Android Developer Toolkit version 22.0.0 or above.  Current version is 21.0.0.v201102162101-104271.  Please update ADT to the latest version. 结果:sdk环境变量无法指定。

原因: 由于更新后,android-sdk-windows/tools/lib下的plugin.pro文件内容变为 # begin plugin.prop plugin.version=22.0.0 # end plugin.prop

而Eclipse在查看该文件时,查找到plugin.version=17.0.0,认为当前的sdk需要22.00版本以上的插件,但我们还是以前旧 的插件。 解决方法: 将plugin.version的版本信息改为旧版本的版本号,诸如10.0.0. 修改为plugin.version=10.0.0,保存,重启Eclipse。

共有 人打赏支持
粉丝 7
博文 83
码字总数 60050
评论 (1)
行走的班渠
招技术,加我微信啊我是做互联网消费金融的,微信号bentleyban
×
happyliferao
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: