关于Vue版本的使用

原创
2020/10/01 12:01
阅读数 296

前言

yuebonCore中vueUI它基于 vue 和 element-ui实现。它使用了最新的前端技术栈,内置了动态路由,权限验证,提炼了典型的业务模型,提供了丰富的功能组件,它可以帮助你快速搭建企业级中后台产品原型。

你需要在本地安装 node 和 git。本项目技术栈基于 ES2015+、vue、vuex、vue-router 、vue-cli 、axios 和 element-ui,提前了解和学习这些知识会对使用本项目有很大的帮助。

步骤操作

1、你需要在本地安装 node 和 git。

2、克隆项目 git clone https://gitee.com/yuebon/YuebonNetCore.git

3、进入项目目录

cd vueUI

4、安装依赖

npm install

建议不要用 cnpm 安装 会有各种诡异的bug 可以通过如下操作解决 npm 下载速度慢的问题

npm install --registry=https://registry.npm.taobao.org

6、本地开发 启动项目

npm run dev

7、打开解决方案,启动Yuebon.Webapi项目

注意:启动后需要修接口访问地址,在vueUI -> src目录下settings.js的文件中修改

强烈建议不要用直接使用 cnpm 安装,会有各种诡异的 bug,可以通过重新指定 registry 来解决 npm 安装速度慢的问题。若还是不行,可使用 yarn 替代 npm。

Windows 用户若安装不成功,很大概率是node-sass安装失败。解决node-sass安装不成功的问题

npm i node-sass --sass_binary_site=https://npm.taobao.org/mirrors/node-sass

另外因为 node-sass 是依赖 python环境的,如果你之前没有安装和配置过的话,需要自行查看一下相关安装教程。

vue项目打包命令:

npm run build:prod --report

传送门:

element-ui 官网点击进入

vue-element-admin 点击进入

常见问题

1、启动后出现如错误:Module build failed (from ./node_modules/babel-loader/lib/index.js):

解决方法:进入当前项目目录 npm install @babel/core @babel/preset-env 命令

如果使用有任何疑问,可以联系作者微信:13524377688

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部