Plugin is too old, please update to a more recent

原创
2016/02/04 18:58
阅读数 1W

解决方法如下

第一种,最简单,但是不推荐这么做

将build.gradle 里的类似

classpath 'com.android.tools.build:gradle:2.0.0-alpha9'

改成

classpath 'com.android.tools.build:gradle:1.5.0'

或者

classpath 'com.android.tools.build:gradle:1.3.0'

这是不推荐的方法,但是简单可行

 

第二种方法,这才是解决方法的正确方式

首先下载

https://services.gradle.org/distributions/gradle-2.10-all.zip

当然如果有新的,也可以下新的,这个如果你不知道下载地址,其实studio会提醒你的

然后打开路径

\android-studio\gradle

 将下载的文件夹放到这里

然后打开studio,settting-》build,execution,deployment->gradle    修改路径到

android-studio/gradle/gradle-2.10

然后就可以了

当然,也许你应该修改项目的的设置,打开项目位置

MyApplication\gradle\wrapper

修改文件gradle-wrapper.properties

#Wed Oct 21 11:34:03 PDT 2015
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip

类似这样的就可以了

展开阅读全文
打赏
2
4 收藏
分享
加载中
更多评论
打赏
0 评论
4 收藏
2
分享
返回顶部
顶部