关于fragment
关于fragment
yolinfeng 发表于3年前
关于fragment
  • 发表于 3年前
  • 阅读 7
  • 收藏 0
  • 点赞 0
  • 评论 0

【腾讯云】如何购买服务器最划算?>>>   

(1)android.app.Fragment:兼容的最低版本是android:minSdkVersion="11"

因此你的应用不能兼容3.0以下的应用。

可以使用<fragment>标签的,这点很重要,如果是用android.support.v4.app.Fragment的话,是不能是用<fragment>标签的,会抛出android.view.InflateException: Binary XML file line #7: Error inflating class fragment异常

(2)android.support.v4.app.Fragment:可以兼容到1.6的版本,不能使用<fragment>标签,需要在程序中通过add或者replace的方式添加,同时还需要

android-support-v4.jar
fragment的使用教程请大家参考官网的demo,那个是以android.app.Fragment为例子的,可以使用getFragmentManager(),activity的一个方法,

要是用android.support.v4.app.Fragment,需要继承FragmentActivity,使用getSupportFragmentManager,这两个方法都是为了

得到fragmentManager,名字一样但是包名不一样。

共有 人打赏支持
粉丝 11
博文 196
码字总数 11946
×
yolinfeng
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: