mac10.9安装jdk7后eclipse、intellij、pycharm启动问题解决
mac10.9安装jdk7后eclipse、intellij、pycharm启动问题解决
youngjdong 发表于4年前
mac10.9安装jdk7后eclipse、intellij、pycharm启动问题解决
  • 发表于 4年前
  • 阅读 1306
  • 收藏 2
  • 点赞 2
  • 评论 0

移动开发云端新模式探索实践 >>>   

摘要: mac jdk7

eclipse

eclipse-on-mac-10-8-installed-1-7-0-jre-jdk-but-eclipse-wont-launch launcher eclispe must use jre6,so run it from the terminal

./eclipse

Info.plist
对于此问题只需要修改jdk安装目录下的Info.plist文件,然后重启系统即可: 如,我的系统上是修改:/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Info.plist 文件,将这部分

<key>JVMCapabilities</key> <array> <string>CommandLine</string> </array>

修改为一下即可: <key>JVMCapabilities</key> <array> <string>JNI</string> <string>BundledApp</string> <string>WebStart</string> <string>Applets</string> <string>CommandLine</string> </array>

idea

To force running under JDK 1.7 edit /Applications/<Product>.app/Contents/Info.plist file, change JVMVersion from 1.6* to 1.7* :

<key>JVMVersion</key> <string>1.7*</string>

pycharm

editing Info.plist inside /Applications/PyCharm.app/Contents Replace the JVM version from 1.6* to 1.7*

  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 9
博文 34
码字总数 6016
×
youngjdong
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: