文档章节

linux下升级python版本

xbuding
 xbuding
发布于 2016/05/27 00:19
字数 269
阅读 128
收藏 6

下载安装包,下载地址:https://www.python.org/downloads/,我下载的是3.5.1

解压安装包,并且cd到解压的目录下面。

tar -xvf Python-3.5.1.tar.xz
cd Python-3.5.1

然后新建一个python3的文件夹,需要权限 + sudo

mkdir /usr/local/python3

编译安装

./configure --prefix=/usr/local/python3
make
make install

由于存在之前的老版本的python,为了防止意外,先备份下来,避免栉jie风沐雨覆盖掉。

mv /usr/bin/python /usr/bin/python_old

再建立新版本python的链接

ln -s /usr/local/python3/bin/python3 /usr/bin/python

,然后在终端输入python

Python 3.5.1 (default, May 26 2016, 23:55:32) 
[GCC 5.2.1 20151010] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> 

升级可能会引起pip等不能使用,需要升级,如果没安装可以,可:

wget "https://pypi.python.org/packages/source/p/pip/pip-1.5.4.tar.gz#md5=834b2904f92d46aaa333267fb1c922bb" --no-check-certificate
tar -xzvf pip-1.5.4.tar.gz
cd pip-1.5.4
python setup.py install

 如果pip安装后提示依然没有pip命令,需在在添加环境变量

vim /etc/profile
#添加
export PATH="/usr/local/python3/bin:$PATH"
#保存退出
#生效profile文件
source /etc/profile

 

© 著作权归作者所有

上一篇: cheerio的小案例
下一篇: Mock.js的使用
xbuding
粉丝 4
博文 35
码字总数 12103
作品 0
广州
私信 提问
如何在linux下升级python

服务linux器自带的是python2.6.无法安装 pip install paramiko。总是报错。 系统自带的Python2.6又不能动。无奈只好再安装一个版本。 自己尝试手动升级python2.7 最后还是放弃了,因为安装成...

linuxprobe16
2018/12/01
13
0
Firefly 零基础部署图文教程

python基础环境搭建 window下环境变量设置 设置后可以方便的使用python命令行,以及python路径下的Script工具。 1.python的安装路径 2.python script 工具的路径 这两个路径加入到path环境变...

大鸡蛋
2013/09/11
20
0
升级python2.6===升级至3.6.1版本

虚拟机安装的linux 6.7版本,自带的python是2.6,如果不需要升级python版本的可以直接安装ipython [root@adsl-172-10-0-3 ~]# python -V ----查看python版本 [root@adsl-172-10-0-3 ~]# yum ...

zhengminghao
2018/06/29
0
0
升级 PG9.3的一点心得体会 -- 关于python 3.3

决定这么做的时候, 就没有想过要回头了. PG本身并没有带来任何麻烦. 但是有一些数据库模块是基于plpython的, 所以, 也针对python 进行升级, 从3.2 到3.3 结果模块发生很多意想不到的问题. 究...

宏哥
2013/09/12
263
0
python---linux下升级python的版本

我的linux系统:centos5.5 我要升级的版本是:2.7.3(目前我更新操作的最新版本【是在2这个系列中的,你也可以安装3系列的】) 升级python的步骤 参考资料如下: http://liluo.org/2010/08/c...

durban
2012/04/15
16K
0

没有更多内容

加载失败,请刷新页面

加载更多

Dubbo-自适应拓展机制

背景 在 Dubbo 中,很多拓展都是通过 SPI 机制进行加载的,比如 Protocol、Cluster、LoadBalance 等,这些都是Dubbo的基础组件。这些基础组件的拓展不是在系统框架启动阶段被加载,而是拓展方...

rock-man
31分钟前
5
0
Kali安装fcitx输入法(五笔)

安装fcitx > sudo apt-get install fcitx-rime fcitx-config-gtk3 重启 > sudo reboot fcitx配置 效果就是这样 配置输入法切换 系统设置...

yeahlife
33分钟前
4
0
IE之css3效果兼容

本文转载于:专业的前端网站▷IE之css3效果兼容 一、兼容css阴影效果(ie滤镜) 1.Shadow,阴影 .shadow { -moz-box-shadow: 3px 3px 4px #000; -webkit-box-shadow: 3px 3px 4px #000; box-sha...

前端老手
36分钟前
4
0
NiushopB2C开源商城功能列表说明:

B2C单商户免费版:PC商城+微商城 B2C单商户标准版:PC商城+微商城组合套餐+阶梯优惠核销功能 B2C单商户企业版:PC商城+微商城拼团+组合套餐阶梯优惠+核销功能 B2C单商户分销版:PC商城+微商城...

niushop-芳
37分钟前
4
0
图片如何转GIF图片呢

如何将生活中拍摄的好玩有趣的图片制作成GIF动图呢?相信很多小伙伴都不知道要如何制作,其实制作方法非常的简单,下面分享一个图片转GIF动图的方法,希望这个方法能够帮助大家在与好友斗图时...

白米稀饭2019
44分钟前
4
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部