iOS开发之-cocoaPods
iOS开发之-cocoaPods
断水殇 发表于1年前
iOS开发之-cocoaPods
  • 发表于 1年前
  • 阅读 13
  • 收藏 1
  • 点赞 0
  • 评论 1

【腾讯云】新注册用户域名抢购1元起>>>   

摘要: 要使用的第三方越来越多,传统的方法需要自己去添加一些依赖框架,pod不算完美,但利大于弊,在此记录我的学习笔记。适合新手阅读。

使用目的:第三方类库方便使用,很多第三方已经放在github上,pod就是从git上把需要使用的clone到你的项目中,并且自动设置好需要的系统框架。

缺点:修改起来麻烦,不过熟练了也就那么回事了。

要使用CocoaPods,那就要下载安装它,而下载安装CocoaPods需要Ruby环境终端执行命令。

1、Ruby 环境:http://www.runoob.com/ruby/ruby-tutorial.html

检测:

  1. ritekiMac-mini:PodTest lucky$ ruby -v  
  2. ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]  
  3. ritekiMac-mini:PodTest lucky$

更新:终端输入如下命令(把Ruby镜像指向taobao,从国外服务器转接taobao,不用翻墙)

gem sources --remove https://rubygems.org/ 

gem sources -a https://ruby.taobao.org/ 

gem sources -l  (用来检查使用替换镜像位置成功)

2、OS 10.11之后 需要调整(我学的比较晚,因此网络上的文档很多没有更新,下面这段代码是拷贝的,在终端输入)

sudo gem install -n /usr/local/bin cocoapods
再加一句,完美解决
sudo xcode-select --switch /Applications/Xcode.app

3、使用 RVM baby 升级 Ruby到 2.2.2 版本

curl -L get.rvm.io | bash -s stable

安装完之后执行

source ~/.bashrc
source ~/.bash_profile

检测

rvm -v

输出以下结果表示成功,但是这个不是最新的,所以需要升级

rvm 1.27.0 (latest) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

升级Ruby,下面这段代码可以输出版本

rvm list known

安装 Ruby2.2.2

rvm install 2.2.2

4、下载安装 CocoaPods(其他方法:http://www.cnblogs.com/jys509/p/4839803.html

终端输入:sudo gem install cocoapods 

然后根据提示输入密码,等待,以下结果表示安装完成

5、CocoaPods 使用

创建新的项目,为了测试可以创建到桌面上,cd到其目录下,输入命令:

touch Podfile

创建 Podfile 文件 ,该文件记录所有导入的类库
再输入:

vim Podfile

按 i 开始编辑,按 esc 终止编辑,按 :再输入wq,结束(保存),如果需要强制保存退出,只要你是root管理员就可以输入:wq!,例如:

再输入:

pod install

开始下载,如果此时下载失败,按照如下格式输入(注:两张图片里要下载的东西是不一样的,注意下载的格式就行了):

更新:

pod update

附:

1、关于Podfile文件编辑时,第三方库版本号的各种写法:

pod ‘AFNetworking’      //不显式指定依赖库版本,表示每次都获取最新版本
pod ‘AFNetworking’,  ‘2.0’     //只使用2.0版本
pod ‘AFNetworking’, ‘>2.0′     //使用高于2.0的版本
pod ‘AFNetworking’, ‘>=2.0′     //使用大于或等于2.0的版本
pod ‘AFNetworking’, ‘<2.0′     //使用小于2.0的版本
pod ‘AFNetworking’, ‘<=2.0′     //使用小于或等于2.0的版本
pod ‘AFNetworking’, ‘~>0.1.2′     //使用大于等于0.1.2但小于0.2的版本,相当于>=0.1.2并且<0.2.0
pod ‘AFNetworking’, ‘~>0.1′     //使用大于等于0.1但小于1.0的版本
pod ‘AFNetworking’, ‘~>0′     //高于0的版本,写这个限制和什么都不写是一个效果,都表示使用最新版本

2、参考网址

http://blog.csdn.net/prl18353364833/article/details/52460124

http://www.cnblogs.com/jys509/p/4839803.html

如果遇到安装pod失败的情况,并且推测是网络原因,请参考下面链接,写的很详细,我就不再多言了。

http://www.cocoachina.com/bbs/read.php?tid=193398&page=1

  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 1
博文 6
码字总数 4715
评论 (1)
小码爱大牛
你好,我是深圳一家以家居安防为核心的智能家居公司的HR在招聘一位会ffmpeg的Android开发工程师和一位iOS开工程师。不知道您自己或者身边同事朋友有没有在看工作机会的呢?如果感兴趣可以发简历到3288771685@qq.com或者加起QQ。
×
断水殇
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: