Eclipse IDE支持Java 14

原创
2020/03/23 08:52
阅读数 1W

随着JDK 14的发布(https://my.oschina.net/waylau/blog/3197270),各大Java IDE也开始支持JDK 14。最新版本的Eclipse IDE 2020-03也于2020年3月18日发布,本文介绍如何通过Eclipse IDE来开发Java 14应用。

下载

下载地址https://www.eclipse.org/downloads/packages/

根据个人的需要,下载Java Developers或者Enterprise Java Developers版本。

设置JDK

下载最新的JDK 14,并在Eclipse IDE中指向该JDK。

设置Maven

可选。如果项目是使用Maven管理,则建议下载最新的Maven,并在Eclipse IDE中指向该Maven。

设置网络代理

为了更快的下载插件,需要设置代理。

设置代码样式

可选。设置符合自己需求的代码样式。

设置字符

建议使用UTF-8。

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-jmwfyiDA-1584924723266)(https://waylau.com/images/post/20200323-08-encoding.png)]

安装支持Java 14的插件

由于当前的Eclipse还未正式支持Java 14,需要额外安装Java 14 Support for Eclipse 2020-03 (4.15)插件,用以支持Java 14。插件地址:

https://marketplace.eclipse.org/content/java-14-support-eclipse-2020-03-415

安装完成之后,就可以选择使用JDK 14的编译器,同时启用预览功能。

编程

终于可以愉快的玩耍了Java 14了。

本文所有源码可见https://github.com/waylau/modern-java-demos

参考引用

展开阅读全文
打赏
1
5 收藏
分享
加载中
该评论暂时无法显示,详情咨询 QQ 群:912889742
有啥好的插件吗
2020/03/23 14:56
回复
举报
waylau博主
2020/03/23 15:00
回复
举报
waylau博主
参考上文,设置网络代理,可以加快下载速度
2020/03/23 14:57
回复
举报
添加一个8.8.8.8吗 感觉没用
2020/03/23 20:50
回复
举报
waylau博主
yes
2020/03/23 21:54
回复
举报
更多评论
打赏
6 评论
5 收藏
1
分享
返回顶部
顶部