ubuntu 12.04 gem install rails fails
ubuntu 12.04 gem install rails fails
黄俊que 发表于4年前
ubuntu 12.04 gem install rails fails
  • 发表于 4年前
  • 阅读 33
  • 收藏 0
  • 点赞 0
  • 评论 0

【腾讯云】新注册用户域名抢购1元起>>>   

root@E430c:/usr/share/ruby-rvm/scripts# gem install rails
Successfully installed rails-4.1.1
1 gem installed
Installing ri documentation for rails-4.1.1...
file 'lib' not found
Installing RDoc documentation for rails-4.1.1...
file 'lib' not found
root@E430c:/usr/share/ruby-rvm/scripts# gem install gollum
Building native extensions.  This could take a while...
ERROR:  Error installing gollum:
    ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9.1 extconf.rb
checking for main() in -licui18n... no
checking for main() in -licui18n... no


***************************************************************************************
*********** icu required (brew install icu4c or apt-get install libicu-dev) ***********
***************************************************************************************
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.


還沒找到好的解決方案啊。。

  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 1
博文 13
码字总数 5514
×
黄俊que
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: