No repository found at http://m2eclipse.sonatyp...
博客专区 > chaney 的博客 > 博客详情
No repository found at http://m2eclipse.sonatyp...
chaney 发表于4年前
No repository found at http://m2eclipse.sonatyp...
  • 发表于 4年前
  • 阅读 215
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 十分钟定制你的第一个小程序>>>   

eclipse安装maven插件的问题

  1. 安装插件出现No repository found at http://m2eclipse.sonatype.org/sites/m2e错误

        后来用如下地址安装成功:

        http://download.eclipse.org/technology/m2e/releases

   2.  如果 你在安装的时候报如下错误:

         Cannot complete the install because one or more required items could not be found.
  Software being installed: m2e - Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.feature.feature.group 1.4.0.20130601-0317)
  Missing requirement: async-http-client 1.6.5.20130531-2315 (com.ning.async-http-client 1.6.5.20130531-2315) requires 'package org.slf4j 1.6.2' but it could not be found
  Cannot satisfy dependency:
    From: Maven Archetype Common Bundle 1.4.0.20130531-2315 (org.eclipse.m2e.archetype.common 1.4.0.20130531-2315)
    To: bundle org.eclipse.m2e.maven.runtime [1.4.0,1.5.0)
  Cannot satisfy dependency:
    From: m2e - Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.feature.feature.group 1.4.0.20130601-0317)
    To: org.eclipse.m2e.archetype.common [1.4.0.20130531-2315]
  Cannot satisfy dependency:
    From: Embedded Maven Runtime Bundle 1.4.0.20130531-2315 (org.eclipse.m2e.maven.runtime 1.4.0.20130531-2315)
    To: bundle com.ning.async-http-client [1.6.5,1.6.6)

说明它缺少 slf4j 的依赖

点击installing software 输入 http://www.fuin.org/p2-repository/

点开 "Maven osgi-bundles" 

然后选择 "slf4j-api" 安装

再执行第一步操作

3. 如果你在安装的时候出现如下错误:

   Cannot complete the install because of a conflicting dependency.
  Software being installed: m2e - Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.feature.feature.group 1.4.0.20130601-0317)
  Software currently installed: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)
  Only one of the following can be installed at once: 
    This version of m2eclipse cannot be installed on top of the already installed m2eclipse. Uninstall the previous version of m2eclipse and try the install again. 1.4.0.20130601-0317 (org.maven.ide.eclipse 1.4.0.20130601-0317)
    Maven Integration for Eclipse 0.12.1.20110112-1712 (org.maven.ide.eclipse 0.12.1.20110112-1712)
  Cannot satisfy dependency:
    From: m2e - Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.feature.feature.group 1.4.0.20130601-0317)
    To: bundle org.maven.ide.eclipse [1.4.0.20130601-0317]
  Cannot satisfy dependency:
    From: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)
    To: org.maven.ide.eclipse [0.12.1.20110112-1712]

说明你的插件版本过高,需要依赖的包此eclipse暂时没有,所以你可以下载如下版本,前提是你要卸载之前的版本

http://download.eclipse.org/technology/m2e/releases/1.3


共有 人打赏支持
粉丝 4
博文 11
码字总数 6339
×
chaney
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: