说说我在配置ELK 5.x时碰到的问题

原创
2017/05/06 15:05
阅读数 17

首先安装elasticearch head插件,通过plugin命令安装时报错:

提示找不到插件,后来通过github(https://github.com/mobz/elasticsearch-head)上的文档才知道5.x版本以后不支持这钟方式安装head插件,需要从github上clone代码安装,单独启动一个服务来运行。

于是按照说明通过npm install 来安装,结果又碰到个问题:

通过网上搜索了解是license配置问题,修改package.json,把license改为:"license": "Apache-2.0"即可。

但是打开http://localhost:9100/页面无法连接到elastic-search,后来发现elastic-search缺少配置,于是加上了下面几项配置:

http.enabled: true
http.cors.enabled: true
http.cors.allow-origin: "*"

终于可以连接上了,出现了令人喜悦的绿色条。

 

elastic-search配置完后开始配置kibana,kibana比较简单,下载后可以直接启动。

最后启动logstash,

注:启动参数里面不能有中划线。

在kibana管理页面配置elastic-search索引就可以搜索日志了。

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部