glibc库版本低编译还报错?这个方法帮你解决

原创
2023/06/02 10:19
阅读数 2.5K

Glibc 包含了linux一些主要的C库,用于分配内存、搜索目录、打开关闭文件、读写文件、字串处理、模式匹配、数学计算等。

 

 

make工具

注意由于AW服务器make版本为3.8.1,在编译glibc高版本时候不兼容,所以需要更新make工具。假如服务器make版本较高,可以不用更新make工具。

网址 http://ftp.gnu.org/pub/gnu/make ,下载最新版本4.3。解压后,对make工具进行安装。进入make-4.3源码目录,执行以下命令。

# prefix 后面路径为make工具安装路径,这里我们指定安装到out目录下。
./configure --prefix=${path}
make 
make install

安装完成,我们看到make 4.3版本

glibc源码下载

网址 http://ftp.gnu.org/pub/gnu/glibc/ ,下载所需的glibc版本,注意gcc工具链版本和glibc版本需要匹配。

如下图所示是准备好编译脚本env. sh,glibc各个版本源码。

env.sh是把所有编译步骤整合在一起的脚本,可以根据具体情况单独执行每条指令。

打开脚本env.sh脚本。第4行是gcc位置,第5行是make工具位置(不需要安装高版本make可以去掉),第7行是glibc版本,第12行是glibc源码路径,第13行是glibc生成库文件路径,第14行是glibc编译过程产生中间文件存放路径,第16行是修改环境变量,使用我们自己的make和gcc工具。第30-33行,用于编译glibc。

其中31行 --host=arm-none-linux-gnueabihf ,host填入值要和gcc匹配 ,否则会出差。

运行env.sh脚本

./env.sh

注意下信息,我们可以看到glibc生成准备环境时候,已经使用了我们指定gcc工具链,make工具。


编译完成后,我们看到对应so库

替换glibc,例如在我们测试demo,修改Makefile,指定到我们glibc版本路径即可

重新编译,查看对应执行文件,看到已经使用对应版本版本glibc库

strings main | grep glibc

版本匹配问题

1、gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabi版本,glibc 2.29以下版本都可以编译通过

2、gcc-arm-10.3-2021.07-x86_64-arm-none-linux-gnueabihf版本,目前只在glibc 2.33编译通过,其他版本需测试。

展开阅读全文
加载中
点击引领话题📣 发布并加入讨论🔥
打赏
0 评论
2 收藏
0
分享
返回顶部
顶部