CocoaPods安装和使用
CocoaPods安装和使用
行云流水8848 发表于2年前
CocoaPods安装和使用
  • 发表于 2年前
  • 阅读 19
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 技术升级10大核心产品年终让利>>>   

CocoaPods安装和使用

CocoaPods应该是iOS最常用最有名的类库管理工具了,通过cocoaPods,只需要一行命令就可以完全解决。
重要的是,绝大部分有名的开源类库,都支持CocoaPods。

1. ruby 环境
   --MAC系统自带

2. 什么是gem
   Gem是一个管理Ruby库和程序的标准包,它通过Ruby Gem(如 http://rubygems.org/ )源来查找、安装、升级和卸载软件包,非常的便捷。
   
   添加淘宝的RubyGems镜像
   $ gem sources --add https://ruby.taobao.org/ --remove https://rubygems.org/

   $ gem sources -l

   安装Cocoapods
   $ sudo gem install cocoapods

   安装成功以后,接着执行命令
   $ pod setup

   检索第三方类库
   $ pod search SDWebImage

3. 创建项目,命令行进入项目主目录

   创建Podfile文件
   $ touch Podfile

   编辑 Podfile文件
   vim Podfile

   Podfile文件内容
    
    platform :ios, '8.0'
    pod "SDWebImage"


4. 执行命令
   $ pod install


   这个时候,项目文件夹下面多了一个文件,xxxx.xcworkspace
   以后双击该文件,打开项目

可能出现的问题

1. 如果需要更新Ruby环境,执行以下语句
   $ sudo gem update --system
 
2. 如果上面因为权限问题安装失败,必须每次都要删除
   $ rm -rf /Users/loginnanme/Library/Caches/CocoaPods/

3. 关于Podfile文件编辑时,第三方库版本号的各种写法:

   pod ‘AFNetworking’      //不显式指定依赖库版本,表示每次都获取最新版本
   pod ‘AFNetworking’,  ‘2.0’     //只使用2.0版本
   pod ‘AFNetworking’, ‘>2.0′     //使用高于2.0的版本
   pod ‘AFNetworking’, ‘>=2.0′     //使用大于或等于2.0的版本
   pod ‘AFNetworking’, ‘<2.0′     //使用小于2.0的版本
   pod ‘AFNetworking’, ‘<=2.0′     //使用小于或等于2.0的版本
   pod ‘AFNetworking’, ‘~>0.1.2′     //使用大于等于0.1.2但小于0.2的版本,相当于>=0.1.2并且<0.2.0
   pod ‘AFNetworking’, ‘~>0.1′     //使用大于等于0.1但小于1.0的版本

   pod ‘AFNetworking’, ‘~>0′     //高于0的版本,写这个限制和什么都不写是一个效果,都表示使用最新版本

4. 出现以下错误,

   ERROR:  While executing gem ... (Errno::EPERM)
   Operation not permitted - /usr/bin/xcodeproj

   ERROR:  While executing gem ... (Errno::EPERM)
   Operation not permitted - /usr/bin/pod

   解决方法
   sudo gem install -n /usr/local/bin cocoapods


共有 人打赏支持
粉丝 8
博文 22
码字总数 125114
评论 (0)
×
行云流水8848
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: