文档章节

听说你很厉害,来试试这个...

you的日常
 you的日常
发布于 2019/12/18 17:20
字数 941
阅读 312
收藏 0

刚在看开源中国动弹的时候,发现了这样的一条记录 file

很好奇这里提到的#文言#是什么项目,虽然程序员都是 直肠子, 但是这也太直白了一点。然后就点开了,这一点好像发现了新世界。

文言 项目是什么

文言(wenyan-lang)是一门采用文言文输入的编程语言,该语言不包括英文字符,仅包含繁体中文字符,并保留繁体引号「」。

file

简单点来说,就是使用文言文来编程。听说你很厉害,那来看看项目主页上面的序言部分

夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸之木鳶,善於武侯之流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。鼠、蟹、鑽、魚,或以速稱。蛇、象、駱、犀,各爭文采。方知鬼之所以夜哭,天之所以雨粟。 然以文言編程者 ,似所未有。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羁于远邦,兩耳久旷于雅言。然夫文章者吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。 誠未能嘔瀝長吉之心血,亦庶幾免於義山之流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。 自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡抚掌而甘心,平子見陋而固宜。 然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。

file

看看这介绍,从文字历史说起、再说明了这么做的初衷、然后作者自谦了一把,最后还是不忘请大家来一起参与。

Helloworld

程序员对 Helloworld 有特殊的感情,还是从这里开始。

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
	吾有一言。曰「「問天地好在。」」。書之。
云云。

编译成 JavaScript

var n = 3;
for (var i = 0; i < n; i++) {
	console.log("問天地好在。");
}

然后输出

問天地好在。
問天地好在。
問天地好在。

作者还好意提醒道:标点符号和换行完全是可选的(就像他们在中国古典),所以上面的代码就相当于:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

看看作者这专业程度。

语法定义

变量

控制

运算

容器

函数

提供的功能

依照官网的介绍,具有下面的特性:

Online IDE

作者还提供了Online IDE :http://wenyan-lang.lingdong.works/ide.html

画风是这样的 file file

其它信息

作品第一次提交 2019 年 10 月 9 日 file

在最大的同性交友平台上收获了 4.4 K 的 star, 看来还是很受欢迎的. 4.4 K 的 star


感兴趣的朋友,可以去试试看。 不说了,我去学习新语言了。

本文由博客一文多发平台 OpenWrite 发布!

© 著作权归作者所有

you的日常
粉丝 2
博文 4
码字总数 8305
作品 0
同里
高级程序员
私信 提问
加载中

评论(0)

刚才软通动力给我打电话,让我过去……

他们和华为合作一个湖北电信的项目需要人 听说他们加班很凶,但是招聘人员和我说他们加班不厉害 我还是很担心

戴威
2012/06/14
2.2K
14
关于 lighttpd 和它的流行看出 开源社区是如何的不严谨

早年听说lighttpd很厉害. 但是在确定部署的时候, 还是留了个心眼. lighttpd是一个web前置机. 所有的前置机都面临一个问题, 就是前段的并发连接, 最终是转换为后端有限连接, 并进行流水线话....

宏哥
2013/09/26
852
2
程序员的幽默,不是一个bug就能解释清楚的

有一次想要用电脑调试一下手机,但是usb连上了手机怎么都不显示usb调试。我拔了又插,重启电脑,重启手机,各种咒骂,最后发现是把usb另一端插在了另一个电脑上。 我是一个软件测试的工程师,...

如蜗牛般努力
2017/12/06
0
0
谁有 PHP+Mysql+Redis 邮件队列的栗子

听说Redis 很牛 想试试,

CuiQG丶
2015/02/03
593
2
ArcGIS 报错No server configured. At least one ser...

今天生产环境的arcgis突然挂了。重启服务后,rest服务一直起不来。从日志观察发现有三个错误。 由于找不到数据库 arcgissecuritystore,已拒绝连接。 Unable to connect to host: svctag-88...

我是潮汐
2013/06/25
205
0

没有更多内容

加载失败,请刷新页面

加载更多

被关系数据库建表和升级折磨?因为你没用大道至简的Flyway

前言 六年前Flyway已经是我TDD开发、持续集成工具栈中的重要一环了,作为早期用户,我早就应该为它做个”广告“,可惜对创业者来说时间太宝贵了,现在趁着疫情才有机会在家里总结点东西。虽然...

chentao106
8分钟前
44
0
解决ClientDataSet连接脱离框架导致某些字段无法在客户端修改值的问题

{ function: 解决ClientDataSet连接脱离框架导致某些字段无法在客户端修改值的问题 description: 将一个复制Data的clientdataset做成可写。因为直接赋值cdsData.data=cdsTemp.data会连着dat...

乞丐88
10分钟前
27
0
Java日期时间API系列25-----Jdk8中java.time包中的新的日期时间API类,使用MonthDay计算十二星座。

  通过Java日期时间API系列24-----Jdk8中java.time包中的新的日期时间API类,MonthDay类源码和应用,对比相同月日时间。对MonthDay简单做了说明和应用。十二星座是根据公历生日类计算属于哪...

侠客张三
16分钟前
40
0
iOS在应用初始化阶段可能会执行的一些动作

排名不分先后 检查应用是否为首次启动。 检查用户是否已经登陆。 如果用户已经登录,尽可能地载入之前的状态。 连接服务器以拉取最新的变更。 检查应用是否由某个深层链接唤起。如果是,还需...

mouos
18分钟前
46
0
我可以从Django中的模板访问settings.py中的常量吗?

我希望通过模板访问settings.py中的一些内容,但是我不知道该怎么做。 我已经试过了 {{CONSTANT_NAME}} 但这似乎不起作用。 这可能吗? #1楼 如果使用基于类的视图: ## in settings.py#...

技术盛宴
21分钟前
38
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部