文档章节

OpenWrt中设置PPTP客户端和IPv6

netgator
 netgator
发布于 2015/02/08 18:50
字数 958
阅读 1615
收藏 16

好几年前买的Dlink DIR-605(HW ver:B1),在网上搜索发现和国外的DIR-615D是一样的配置,可以刷DD-Wrt(下载地址http://dd-wrt.com/site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F)。DD-Wrt的ROM可以支持PPTP客户端,但4M flash的版本不支持IPv6。刷了二年多以后,某些网站被封了,但是通过IPv6可以访问。于是开始寻找支持IPv6的ROM。

编译DD-Wrt资料不是很丰富,找了一圈就放弃了。原来刷DD-Wrt后也尝试过刷OpenWrt,现在想想失败的原因就是没弄清factory和sys upgrade两种刷ROM方式。换不同厂商的ROM必须使用factory方式,同一个厂商的才用web管理工具中的upgrade方式。

先根据DIR-605路由器的CPU(Ralink RT3052 id:1 rev:2) 用笔记本(台式机同样操作)下载OpenWrt Barrier Breaker 14.07的ROM(下载地址 https://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/)。关闭路由器电源,用一小棍顶住reset按钮,然后插上路由器电源。路由器电源指示灯呈黄灯闪烁时就可以松开reset按钮,此时路由器已进入factory刷新方式。由于路由器的IP地址为192.168.0.1,所以将笔记本的有线网卡IP设置为192.168.0.2,   通过网线将笔记本与路由器连接。用笔记本的浏览器访问网址192.168.0.1,然后选择ROM文件,刷入OpenWrt,此时注意不能断电。刷成功以后路由器会自动重新启动。电源指示灯变绿以后,将笔记本的有线网卡的IP地址改为自动获取。用浏览器访问网址192.168.1.1,就可以开始设置OpenWrt。

使用OpenWrt的Luci不能控制一些设置,所以我使用SSH登录192.168.1.1,也可以使用telnet服务(我关闭了没有尝试)。

这个ROM中默认没有安装PPTP客户端模块,可以手工安装:
# opkg update
# opkg install ppp-mod-pptp
PPTP客户端设置需要使用vi修改/etc/config/network,在最后增加:
config interface 'vpn'
    option ifname 'pptp-vpn'
    option proto 'pptp'
    option username 'PPTP_USER'
    option password 'PPTP_PASSWORD'
    option server 'SERVER_IP'
    option buffering '1'
其中username,password,server都要填PPTP服务器上的。
还需要修改 /etc/config/firewall,找到
config zone
    option name 'wan'

    option network 'wan wan6'
改为
    option network 'wan wan6 vpn'
重新启动路由器,PPTP 客户端配置就生效了。不想重启,可以安装ppp_mppe和pptp内核模块,重启network和firewall服务。

我使用的网络是教育网,IPV6是SLAAC方式。Barrier Breaker号称支持native IPv6,但是默认的配置只有路由器可以通过IPv6访问外网,内部的计算机都不能访问IPv6外网。Luci只能更改lan的DHCP IPv6设置,不能更改其他设备的。由于对IPv6不熟悉,经过好几天的网上搜索,才配置好了IPv6。
/etc/config/network的部分相关配置
config globals 'globals'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '64'

config interface 'wan'
    option ipv6 '1'
    option ifname 'eth0.2'
    option proto 'dhcp'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

/etc/config/dhcp中的部分相关设置(注意:#是注释语句,那些选项必须被注释)
config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option ra 'relay'
#    option dhcpv6 'relay'
    option ndp 'relay'

config dhcp 'wan6'
    option ra 'relay'
 #    option dhcpv6 'server'
   option ndp 'relay'
    option master '1'

#config dhcp 'wan'
#    option interface 'wan'
#    option ignore '1'
网上资料说Barrier Breaker 14.07没有采用较新的odhcpd版本,存在bug,所以IPv6不稳定。内网连不上IPv6时,可以执行以下命令重启odhcpd服务:
# /etc/init.d/odhcpd restart

有了IPv6,网上查找资料感觉方便多了。


补充:Chaos Calmer 出来以后我改用 IPV6 nat 方式















© 著作权归作者所有

netgator
粉丝 0
博文 7
码字总数 4750
作品 0
程序员
私信 提问
OpenWrt系列教程汇总 & OpenWrt简体中文Wiki

OpenWrt系列教程汇总 OpenWrt简体中文Wiki 快速导航

AlphaJay
2011/07/26
42.5K
1
开源路由器项目 OpenWrt 发布 18.06 稳定分支的首个版本

OpenWrt 18.06.0 - First Stable Release - July 2018 OpenWrt 项目是一个针对嵌入式设备的 Linux 操作系统。它完全取代了厂商提供的各种无线路由器和非网络设备的固件。已被支持的设备,请参...

Just_4_Fun
2018/08/01
8.3K
12
悬赏100元!极路由轻松实现的功能OPENWRT实现不了?求踩,求虐

给出操作具体步骤,设置成功后给50元报酬 给出带luci的固件,设置成功后给100元报酬 请留下联系方式 为了防止大学生搞破坏,高校网络普遍采用双重认证模式, 上网流程如下: 第一步,用电脑的...

小折腾
2014/08/01
6.6K
8
流量限速解决方案 - nft-qos

nft-qos 是 RosyWrt 团队为 OpenWrt 和 LuCI 项目研发的流量限速应用,基于全新的 nftables 防火墙以及 OpenWrt master 分支, 目的在于为项目提供一个细粒度(具体到客户端)的限速解决方案...

rosywrt
2018/11/07
1K
1
OpenWRT 14.07 RC1 发布,支持原生 IPv6

路由器Linux发行版OpenWRT发布了14.07 RC1,主要新特性是支持原生IPv6和整合Procd初始化系统。Procd是OpenWRT新的预初始化、初始化、热插拔和事件系统。其它变化包括:Linux内核升级到3.10;...

oschina
2014/07/17
4.5K
6

没有更多内容

加载失败,请刷新页面

加载更多

计算机实现原理专题--二进制减法器(二)

在计算机实现原理专题--二进制减法器(一)中说明了基本原理,现准备说明如何来实现。 首先第一步255-b运算相当于对b进行按位取反,因此可将8个非门组成如下图的形式: 由于每次做减法时,我...

FAT_mt
今天
5
0
好程序员大数据学习路线分享函数+map映射+元祖

好程序员大数据学习路线分享函数+map映射+元祖,大数据各个平台上的语言实现 hadoop 由java实现,2003年至今,三大块:数据处理,数据存储,数据计算 存储: hbase --> 数据成表 处理: hive --> 数...

好程序员官方
今天
7
0
tabel 中含有复选框的列 数据理解

1、el-ui中实现某一列为复选框 实现多选非常简单: 手动添加一个el-table-column,设type属性为selction即可; 2、@selection-change事件:选项发生勾选状态变化时触发该事件 <el-table @sel...

everthing
今天
6
0
【技术分享】TestFlight测试的流程文档

上架基本需求资料 1、苹果开发者账号(如还没账号先申请-苹果开发者账号申请教程) 2、开发好的APP 通过本篇教程,可以学习到ios证书申请和打包ipa上传到appstoreconnect.apple.com进行TestF...

qtb999
今天
10
0
再见 Spring Boot 1.X,Spring Boot 2.X 走向舞台中心

2019年8月6日,Spring 官方在其博客宣布,Spring Boot 1.x 停止维护,Spring Boot 1.x 生命周期正式结束。 其实早在2018年7月30号,Spring 官方就已经在博客进行过预告,Spring Boot 1.X 将维...

Java技术剑
今天
18
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部