Composer install error - requires ext_curl when it's actually enabled

10/14 01:21
阅读数 0

问题:

I'm trying to install Facebook PHP SDK with Composer.我正在尝试使用 Composer 安装 Facebook PHP SDK。 This is what I get这就是我得到的

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

    Problem 1
        - Installation request for facebook/php-sdk dev-master -> satisfiable by facebook/php-sdk[dev-master].
        - facebook/php-sdk dev-master requires ext-curl * -> the requested PHP extension curl is missing from your system.

Problem is, I have curl extension enabled (uncommented in php.ini).问题是,我启用了 curl 扩展(在 php.ini 中未注释)。 When I run phpinfo() , it says it's enabled.当我运行phpinfo() ,它说它已启用。 Only clue I have is that when I run $ php -m , 'curl' line is missing but I don't know what to do about it.我唯一的线索是,当我运行$ php -m ,缺少 'curl' 行,但我不知道该怎么做。

I have wamp 2.4 on Win8 and I'm running composer in cmd.exe.我在 Win8 上有 wamp 2.4,我在 cmd.exe 中运行 composer。


解决方案:

参考一: https://en.stackoom.com/question/1J7zl
参考二: https://stackoom.com/question/1J7zl
展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部