OSPF综合实验

08/11 12:24
阅读数 95

OSPF开放路径最短选择优先协议(IGP协议、链路状态协议)
支持大型网络,通过彼此交互hello建立邻居关系,在通过彼此交互的LSA通过SPF算法算出最优路由的到自己去往其他节点路径。
OSPF的DR、BDR机制和作用
DR(Designated Router),指定路由器
BDR(Backup Designated Router),备份指定路由器
DROther(Designated Router Other),成员路由器
在运行OSPF的设备是MA网络的同区域同网段就需要通过OSPF的hello机制选举DR、BDR,当某台设备发生更新时就发送LSA到DR、BDR,在由DR发送给区域的内的其他设备这样降低LSA交互节省了设备转发资源。
OSPF的区域机制
不同区域通过ABR与其他区域相连接,限制LSA范围,减少LSA传输数量减少LSDB链路状态数据库的大小,节省传输资源内存消耗。种类有:
骨干区域:作为中间区域与其他区域相连接,区域号固定为area 0,允许转发各种LSA。
非骨干路由器:默认区域必须同过ABR路由器与骨干区域相连,如果没有需要做虚链路。
Stub区域:不允许接收4、5、7类LSA外部路由数据,3类LSA去往区域的路由只生成一条默认路由。
NSSA区域:不接收4、5类LSA,生成一条默认3类LSA
ABR区域边界路由器:负责其他区域和骨干区域的连接
ASBR自治系统边界路由器:负责OSPF外部连接,可以做重分发将其他路由协议的路由加入到OSPF中。













实验拓扑
OSPF综合实验
1.IP地址规划
1、拓扑中的IP地址段采用:172.16.AB.X/24:
n其中AB为两台路由器编号组合,例如:R2-R3之间的AB为23,X为路由器编号,例如R3的x=3
2、R1/R4/R6之间的网段为:172.16.146.X/24,其中X为路由器编号。
3、R4/R5/R6之间的网段为:172.16.100.X/24,其中X为路由器编号。
4、所有路由器都有一个loopback 0接口,地址格式为:X.X.X.X/32,其中X为路由器编
号。
5、Internet为外网123.8.8.X/24,并且Internet上loopback0 114.114.114.114/32。
2实验需求
1、要求按照下列标准配置一个OSPF网络。
2、配置一个IP网络,实验逻辑图如图,IP地址由IP地址规划部分规定而定。
3、路由协议采用OSPF,进程ID为2020,RID为loopback0地址。
4、R4/R5/R6相连的三个站点链路OSPF网络类型配置成广播型,其中R5路由器做为永久性
DR。
5、按照图示配置OSPF区域,其中R1/R4/R6之间的区域要配置成完全末梢区域。
6、R2为新并入的站点,由于来不及布线施工而暂时并到R3这个站点上,所在区域为AREA23,配置使得所有网络可达(采用ping测试)。
7、OSPF内部的网络希望通过R5路由器访问Internet,配置R5使其能够满足需求,只考虑内部路由器上路由的实现。
8、AREA 0基于安全的原因配置上MD5认证,密码:cisco
9、AREA 146中,配置R1为指定路由器,R4/R6之间保持two-way的邻居关系。
10、为了减少网络流量,将R1所在的区域汇总成主类网络通告出去。
11、由于R6与R5之间的链路质量较好,适当配置R4使得R1优先选取R6访问自身区域除外的外部网络。
12、在AREA 0以外的所有区域启用OSPF明文认证,密码:cisco1






















1、要求按照下列标准配置一个OSPF网络。
在设备上配置接口IP地址
2、配置一个IP网络,实验逻辑图如图,IP地址由IP地址规划部分规定而定。
R1/R4/R6配置OSPF area146
R1(config)#router ospf 2020 创建OSPF 2020进程
R1(config-router)#network 1.1.1.1 0.0.0.0 area 146 宣告环回口
R1(config-router)#network 172.16.146.1 0.0.0.0 area 146 宣告物理接口
3、路由协议采用OSPF,进程ID为2020,RID为loopback0地址。
R1/R2/R3/R4/R5/R6在OSPF进程配置
R1(config-router)#router-id 1.1.1.1 设置路由器ID
4、R4/R5/R6相连的三个站点链路OSPF网络类型配置成广播型,其中R5路由器做为永久性DR。
R5连接area的物理接口优先级改到最大255
R5(config)#interface Ethernet0/1
R5(config-if)#ip ospf priority 255 现在它就是DR了
也可以为保险将R4/R6的优先级改为0这样它们就不会参与DR选举
5、按照图示配置OSPF区域,其中R1/R4/R6之间的区域要配置成完全末梢区域。
R1/R4/R6在OSPF进程配置为
R1(config-router)#area 146 stub no-summary
6、R2为新并入的站点,由于来不及布线施工而暂时并到R3这个站点上,所在区域为AREA23,配置使得所有网络可达(采用ping测试)。
R5/R3配置vlink虚链路在OSPF进程配置
R5(config-router)#area 35 virtual-link 3.3.3.3 配置为需要连接的对端环回口
7、OSPF内部的网络希望通过R5路由器访问Internet,配置R5使其能够满足需求,只考虑内部路由器上路由的实现。要求只能在R5上进行配置所有OSPF进程设备都可以连接到外网。
在R5S上配置NAT学习到去往internet 114.114.114.114的网络
R5(config)#access-list 1 permit any 创建ACL访问控制列表
R5(config)#ip nat inside source list 1 interface ethernet 0/0 overload
R5 et0/1、s1/0设置为NAT内部接口
R5(config-if)#ip nat inside 将连接OSPF的接口设置nat内部接口
现在虽然R5学习到路径但是其他OSPF设备还没学习到需要配置路由下放让其他路由器学到。
R5(config)#ip route 0.0.0.0 0.0.0.0 123.8.8.1 写一条默认静态路由
R5(config-router)#default-information originate 在OSPF进程中下放该静态默认路由
8、AREA 0基于安全的原因配置上MD5认证,密码:cisco
R4/R5/R6设备在AREA 0接口配置密钥
R5(config-if)#ip ospf message-digest-key 1 md5 cisco
密匙配置好后在R4/R5/R6的OSPF进程area 0中启用认证模式
R5(config-router)#area 0 authentication message-digest
9、AREA 146中,配置R1为指定路由器,R4/R6之间保持two-way的邻居关系。
通过修改R4/R6优先级让它们不参与选举
10、为了减少网络流量,将R1所在的区域汇总成主类网络通告出去。
Area 146的R1汇总最好在下一跳设备设置,在R4/R5的OSPF进程中进行操作
R4(config-router)#area 146 range 172.16.0.0 255.255.0.0 汇总物理接口
R4(config-router)#area 146 range 1.0.0.0 255.0.0.0 汇总环回口接口
OSPF综合实验
11、由于R6与R5之间的链路质量较好,适当配置R4使得R1优先选取R6访问自身区域除外的外部网络。
现在是负载均衡状态,可以通过在修改R4的cost值,让R1选择走R6
OSPF综合实验
R4(config-router)#AREa 146 default-cost 100
OSPF综合实验
R1#show ip ospf database summary 检查ospf数据库摘要,可以看到R4下放路径开销是100,R6是开销1,所以R1优先选R6。
OSPF综合实验















































12、在AREA 0以外的所有区域启用OSPF明文认证,密码:cisco1
在所有的OSPF进程非area 0接口启用
R1(config-if)#ip ospf authentication-key cisco1 创建接口明文密钥
在OSPF进程选择启用区域进行认证
R1(config-router)#area 146 authentication message-digest
邻居都建立成功
OSPF综合实验
OSPF综合实验
OSPF综合实验







展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
在线直播报名
返回顶部
顶部