robot framework浏览器与驱动的匹配

2019/01/08 10:40
阅读数 41

一、谷歌浏览器和火狐浏览器与驱动不匹配产生的问题

1.若在运行过程中出现【Unable to find a matching set of capabilities 】【 WebDriverException : Missing 'type' parameter - Stack Overflow】等报错信息

驱动浏览器的情况为,不能驱动该浏览器,或者浏览器已经起来了,但是输入网址报错

2.原因:浏览器与驱动以及python的版本存在不兼容,需要相匹配

3.解决方法:

A)查看当前浏览器、驱动以及pythonselenium等版本

  1.查看浏览器不在赘述

  2.查看驱动,在驱动的目录下,路径中输入cmd,即在当前路径下调取出cmd(点击键盘上的shift按钮,鼠标右键,选择【在此打开命令窗口】,也可以实现),输入【chromedriver -h】或者【chromedriver -v】可以查看谷歌驱动,同理【geckodriver-h】查看火狐驱动

  3.查看python等版本,【pip list】

B)查看到当前版本之后,需要去查看当前版本是否匹配

  1.谷歌浏览器网上有详细的驱动版本对应浏览器,如我司需要的谷歌浏览器为V41.才能正常运行某项控件,故需要对应的驱动为V0.15,参看对应情况https://www.cnblogs.com/yang842718540/p/9054749.html

  2.火狐浏览器,尝试之后发现最高的火狐浏览器V64,使用当前最新的驱动V23,可以正常调用成功,但是我司需要的火狐浏览器为V50,尝试了V23,V11,V12,V15均不能调用成功,需要再调试!!

  3.IE浏览器,我司对ie浏览器没有版本要求,故用最新即可以正常驱动

C)正常匹配之后,即可正常运行

 

二、IE浏览器与驱动

 

1.IE的保护措施比较多,故在使用之前需要将保护等级降到最低

2.如何选择ie驱动,需要与当前selenium的版本保持一致,当前我selenium的版本为3.14.1,故应该找驱动为3.141的

驱动下载网址:

http://selenium-release.storage.googleapis.com/index.html?path=3.141/

最先开始会下载x64位的版本,因为我的selenium的版本为64位的,但是下载完成,配置完时,出现输入框输入1s输入一个字符的情况

通过百度,大神说需要下载x32位的版本,果然,能正常输入!

展开阅读全文
打赏
0
0 收藏
分享
加载中
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部