GmSSL安装过程中出现的问题

2019/05/13 15:25
阅读数 459

GmSSL安装过程中出现的问题

在安装GmSSL的时候出现了很多的问题,为了解决这些问题也是花费了大量的时间,甚至还重新装了一次虚拟机。在解决问题的过程中向很多同学进行求助,但是他们都没有碰到和我类似的问题,因此只能自己一点点的尝试,花费了很长时间,直到上周六才弄好。后来我发现很多同学都和我有相同的问题(这里很想哭,为什么我之前求助的同学都没有遇到和我相同的问题~~~ )在这里补上一一篇博客吧,帮助那些还没有弄好的小伙伴们顺利完成

问题1 下载源

蓝墨云中给的压缩包很多同学反映下载后解压不了(不过我的是可以解压的),如果解压不了就去网站上下载吧。

问题2 安装gcc

在安装gmssl之前先安装工程车,命令为sudo apt install gcc 如果有文件提示错误或安装失败可以按照他给出的提示中apt-get update 更新一下镜像源(这个不同人的问题可能不一样,我的在安装的时候是后20个显示连接失败,有的人是前20个连接失败),更新完镜像源后在执行一次安装命令,基本就可以完成。如果还不能执行成功的同学建议去网上找一下镜像源替换自己虚拟机的,我在安装时更新完镜像源后gcc就可以成功安装了。

问题3 查看是否安装成功时出现的问题

1.错误提示error: while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory

这是由于openssl库的问题,已经有同学在蓝墨云中给出解决方法,按照里面的指示做就可以了,需要注意的是里面的‘lib64’应该更换为‘lib’,否则会提示找不到目录

2.错误提示gmssl:relocation error: gmssl: symbol BIO_debug_callback version OPENSSL_1_1_0d not defined in file libcrypto.so.1.1 with link time reference

这个是我出现的最主要的问题,开始的时候去尝试了蓝墨云中同学们的解答,但尝试后发现依旧不可以,仔细对比后发现错误提示不相同,也就是说出现错误的原因是不一样的,出现这个错误提示的原因是gmssl依赖库路径的问题,libssl.so.1.1和libcrypto.so.1.1没有安装到gmssl的依赖库中,具体解决办法参考连接如下

这里需要注意ldd命令后会显示出依赖库路径,cp命令中的后半部分需要替换成自己的依赖库路径,完全按照链接中的命令是无法完成的。在cp命令时需要进入root中进行操作,否则会被提示权限不够,执行完cp命令后再次查看版本即可成功

上述方法存在问题是有可能会对OpenSSL的某些功能造成损坏,由于我在出现这个问题时已经执行了对gmssl的make操作,因此只能在此基础上进行,如果还没有安装gmssl或者还没有进行make操作时建议去蓝墨云中看一下凌一舟同学给出的解决办法,可以防止对OpenSSL造成损坏

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部