ubuntu 安装vim报错

2019/04/08 19:06
阅读数 46

问题:ubuntu18.04默认没有安装vim,使用 sudo apt install 提示

错误信息:

下列信息可能会对解决问题有所帮助:
下列软件包有未满足的依赖关系:
vim : 依赖: vim-common (= 2:7.4.826-1ubuntu1) 但是 2:7.4.1689-3ubuntu1.1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

 解决办法:

  1. 设置正确的软件源 https://www.linuxidc.com/Linux/2018-08/153709.htm

    2.找到 [软件更新器]->设置->ubuntu软件:选择前三项->更新:重要安全更新和推荐更新。一定要按顺序打开,然后执行

 

sudo apt-get update
 sudo apt-get upgrade
 sudo apt install vim -y

 

 

  

  

  

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部