maven包引入问题ClassNotFoundException: org.elasticsearch.client.Cancellable

2019/04/10 10:10
阅读数 83

业务需要,做搜索功能,在springboot聚合项目下,新建了es模块module 但是在引入elasticsearch依赖的时候,出现了问题

引入相应依赖后

    <dependency>
      <groupId>org.elasticsearch</groupId>
      <artifactId>elasticsearch</artifactId>
      <version>7.6.0</version>
    </dependency>
    <dependency>
      <groupId>org.elasticsearch.client</groupId>
      <artifactId>elasticsearch-rest-high-level-client</artifactId>
      <version>7.6.0</version>
    </dependency>

启动一直报错,但是没道理呀 之后搞不懂为什么引入的明明是7.6.0,为什么会出现个6.4.3,奇怪。 之后在spring-boot-dependencies文件中发现,原来在spring-boot-dependencies标签下进行了版本声明

解决方式,在对应的模块pom.xml中覆盖版本号

ok,问题解决,因为目前elasticsearch最新的版本是7.6.0。作为一个用心不用旧的coder来说,自然得引入最新的了,自然,坑就得踩踩了。 springboot-elasticsearch demo地址

原文出处:https://www.cnblogs.com/chywx/p/12421792.html

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部