小白自学机器学习----3.令人头秃的pytorch安装 (No module named 'tools.nnwrap' 错误)

2019/04/10 10:10
阅读数 197

tensorflow 刚刚会写基础的模块了,今天找到研究方向的代码是pytorch实现的

总是看到这句话,人生苦短,我用pytorch

看来pytorch应该比tensorflow好学,但是!! pytorch的安装,也太让人头秃了,接下来讲讲我是如何艰辛的安装上pytorch

 

1.pychram 直接搜索安装(×)

点击+号,在跳出的窗口中输入torch,点击install package

没过多久,会出现下面的错误,安装失败

2.官网pip 语句安装(×)

查看资料,有同学指出在官网中,有安装用户要求生成pip语句,于是前去围观

按照自己的情况选择,复制命令在terminal中运行

pip install torch===1.4.0 torchvision===0.5.0 -f https://download.pytorch.org/whl/torch_stable.html

显示了ConnecTimeout,于是修改命令,加入--default-timeouts=1000

pip --default-timeout=1000 install torch==1.4.0+cu92 torchvision==0.5.0+cu92 -f https://download.pytorch.org/whl/torch_stab
le.html

看看这安装时间,多门感人啊,4kb,太坑了,放弃

3.清华镜像(×)

听同学说,下载清华镜像可以安装,尝试后,仍然是tools.nnwrap的错误,弃

python -m pip install --upgrade torch torchvision -i https://pypi.tuna.tsinghua.edu.cn/simple

4.官网下载,本地安装(√)

反反复复后,我看到了让我眼前一亮的方法,原理简单暴力,容易理解

上面的问题,很大程度是因为国内网络下载限制,既然使用第三方网站会有网络限制,那么就不用它,直接去找生产商,没有第三方赚差价

https://download.pytorch.org/whl/torch_stable.html

下载两个文件,按照自己的电脑版本下载

cu92: cuda9.2

torch-1.4.0 : torch版本 1.4.0

cp37 : python版本3.7

win: windows 系统

cu92/torch-1.4.0%2Bcu92-cp37-cp37m-win_amd64.whl

cu92/torchvision-0.5.0%2Bcu92-cp37-cp37m-win_amd64.whl

使用迅雷下载,网速可以达到10m/s,速度感人,不到十分钟下完了

下载到本地后,使用terminal

OK! 安装成功!!!

接下来可以愉快的研究代码了

 

原文出处:https://www.cnblogs.com/xieviki650/p/pytorch_install.html

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部