.NET Core + EF 报nuget包不兼容

2019/04/14 12:22
阅读数 127

错误信息如下:

严重性 代码 说明 项目 文件 行 禁止显示状态
错误 NU1107 Microsoft.EntityFrameworkCore 中检测到版本冲突。直接安装/引用 Microsoft.EntityFrameworkCore 2.2.4 到项目 CoreWeb 可解决此问题。
CoreWeb -> CoreWeb.Entities -> Microsoft.EntityFrameworkCore.SqlServer 2.2.4 -> Microsoft.EntityFrameworkCore.Relational 2.2.4 -> Microsoft.EntityFrameworkCore (>= 2.2.4)
CoreWeb -> Microsoft.AspNetCore.App 2.1.1 -> Microsoft.EntityFrameworkCore (>= 2.1.1 && < 2.2.0). CoreWeb C:\Users\garson\Desktop\CoreWeb\CoreWeb\CoreWeb.csproj 1

参考:https://www.cnblogs.com/dudu/p/9096803.html 得出问题出现原因是:nuget包不兼容

升级包,发现无法升级,然后查原因是.net Core版本问题,

升级版本:

下载地址dotnet-core 2.2:https://dotnet.microsoft.com/download/dotnet-core/2.2

 

下载后,VS中以然是没有

然后查资料:https://www.cnblogs.com/stulzq/p/10069412.html 这里发现 dotnet-core2.2需要VS2017 15.9版本支持

看了自己的VS版本:15.8 

更新升级版本到15.9:

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部