hue搭建

2019/07/04 11:55
阅读数 1.2K

1.安装依赖:

sudo yum -y install gcc-c++ asciidoc cyrus-sasl-devel cyrus-sasl-gssapi krb5-devel libxml2-devel libxslt-devel mysql-devel openldap-devel python-devel sqlite-devel openssl-devel gmp-devel libffi-devel openldap-clients

2.下载软件

git clone https://github.com/cloudera/hue.git                        ----从github上下载hue的软件安装包,也可以

git clone https://github.com/cloudera/hue.git branche-4.1    ----来指定版本

3.安装软件

通过git下载下来的是已经解压过的hue安装包,不要解压。如果是自己从官网上下载的安装包,需要解压;

 4.进入hue的目录中:

make apps

make install

报错解决:

No package 'libffi' found
c/_cffi_backend.c:15:17: 致命错误:ffi.h:没有那个文件或目录
#include <ffi.h>
^
编译中断。

解决:

yum -y install libffi-devel

5.启动

build/env/bin/supervisor

配置问题:

参考链接:https://blog.csdn.net/zhulei19931019/article/details/52974271

https://blog.csdn.net/mingming156/article/details/80708260

https://www.cnblogs.com/justinyang/p/8728021.html

https://blog.csdn.net/baidu_33270422/article/details/77327038

https://blog.csdn.net/aquester/article/details/52958622

https://www.jianshu.com/p/ea0fe8d177c0

http://www.pianshen.com/article/1559153030/

 

展开阅读全文
打赏
0
1 收藏
分享
加载中
更多评论
打赏
0 评论
1 收藏
0
分享
返回顶部
顶部