[Liunx]apt-get安装软件:依赖冲突问题及解决

2019/09/05 12:12
阅读数 760

正常使用apt-get install安装出现依赖冲突问题:

大概是这样:

ga@ubuntu:~$ sudo apt-get install gcc-5-base:i386 正在读取软件包列表... 完成 正在分析软件包的依赖关系树
正在读取状态信息... 完成
gcc-5-base:i386 已经是最新版 (5.4.0-6ubuntu1~16.04.11)。 gcc-5-base:i386 已设置为手动安装。 您可能需要运行“apt-get -f install”来纠正下列错误: 下列软件包有未满足的依赖关系: cpp-5 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 g++-5 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 gcc-5 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 gcc-5-base : 破坏: gcc-5-base:i386 (!= 5.4.0-6ubuntu1~16.04.10) 但是 5.4.0-6ubuntu1~16.04.11 正要被安装 gcc-5-base:i386 : 破坏: gcc-5-base (!= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libasan2 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libatomic1 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libcc1-0 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libcilkrts5 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libgcc-5-dev : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libgomp1 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libitm1 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 liblsan0 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libmpx0 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libquadmath0 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libstdc++-5-dev : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libstdc++6 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libtsan0 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 libubsan0 : 依赖: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) 但是 5.4.0-6ubuntu1~16.04.10 正要被安装 E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

1 不用的造成冲突的.deb安装包可以删掉。 2 若仍有,且sudo apt-get install -f 仍无法解决的依赖冲突, 观察依赖冲突的具体版本冲突,使用``可以选择指定版本安装。 3 若指定安装过程中报类似,是覆盖文件冲突,可以强制覆盖。

dpkg: 处理归档 /var/cache/apt/archives/gcc-5-base_5.4.0-6ubuntu1~16.04.11_amd64.deb (--unpack)时出错: 尝试覆盖共享的 '/usr/share/doc/gcc-5-base/changelog.Debian.gz', 它与软件包 gcc-5-base:amd64 中的其他实例不同

详见: https://askubuntu.com/questions/989694/how-to-solve-dpkg-error-processing-archive-var-cache-apt-archives-libvlccore9

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部