ubuntu20.04安装mysql5.7版本

2020/07/18 11:43
阅读数 5.1K

    默认情况下,ubuntu20.04版本自带的mysql是8.0,如果我们需要安装5.7版本,我们需要通过如下的方式来安装。

  •     1、直接下载二进制压缩包进行安装,解压并设置相关的参数就可以运行。
  •     2、下载5.7的源,然后通过apt install mysql-server=5.7.31-1ubuntu18.04的方式进行安装。
  •     3、下载5.7的deb文件,然后通过dpkg -i的方式安装。

    这里,主要讲讲后面两种方式的安装,如何通过增加源apt install或者dpkg -i的方式进行安装。这两种安装方式,也是在这篇文章中提到过。

    如果你选择下载mysql-apt-config_0.8.xx-1.all.deb文件,到这里下载,选择一个版本,然后下载到ubuntu中,然后就可以dpkg -i运行,进行配置mysql-server的源。

wget https://repo.mysql.com//mysql-apt-config_0.8.12-1_all.deb
sudo dpkg -i mysql-apt-config_0.8.12-1_all.deb

    执行这一步需要在虚拟机内部执行,如果在securitycrt上面好像无法选择需要的选项。 这个弹出框里,我们需要在第一个默认的选择框中MySQL Server & Cluster选项处点击回车,进入第二个选择页面,选择mysql-5.7的选项然后选择OK,回车保存,再回到这个页面,然后就是如下截图的样子,最后选择OK,回车保存。

    

    之后,运行apt update更新源,这时候会在/etc/apt/source.list.d/目录下生成mysql.list,更新完成,我们通过apt-cache policy mysql-server可以查看到,系统中出现了mysql5.7的源。

     

     这个时候,我们就可以通过apt install mysql-xxx=5.7.31-1ubuntu18.04的方式安装mysql5.7版本了。

apt install mysql-client=5.7.30-1ubuntu18.04
apt install mysql-community-server=5.7.30-1ubuntu18.04
apt install mysql-server=5.7.30-1ubuntu18.04

    这个安装第一次,可能会有缺少依赖包而失败:

     

    解决办法就是,按照提示的缺失包,我们通过apt install即可:

     

    缺失的依赖包安装完成,同时 mysql5.7也安装成功并且启动起来(setting up),在setting up之前,会弹出一个输入mysql root用户的密码输入和确认框,我们输入相同的密码,回车即可。

    这样通过apt install的方式,就安装了mysql5.7版本。

    =====================================================================

    最后再来说说通过dpkg -i mysql-*.deb的方式安装mysql5.7。

wget https://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-server_5.7.31-1ubuntu18.04_amd64.deb-bundle.tar
tar -xvf mysql-server_5.7.31-1ubuntu18.04_amd64.deb-bundle.tar
rm -f mysql-testsuite_5.7.31-1ubuntu18.04_amd64.deb
rm -f mysql-community-test_5.7.30-1ubuntu18.04_amd64.deb
dpkg -i mysql-*.deb

     这种安装方式,需要下载的tar包100多兆,需要解压,解压出来都是deb文件,我们需要通过dpkg -i mysql-*.deb来安装,但是我们不希望安装测试相关的包,所以删除了两个带test名称的deb文件,这样可以快速安装。安装过程也会弹出输入root用户的密码,我们分别输入两次密码,安装完成,mysql就自动启动了,之后就可以使用mysql了。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部