文档章节

华为交换机——DHCP中继实验。超详细,0基础都能看得懂!

o
 osc_1m96ifq3
发布于 07/01 15:48
字数 1154
阅读 51
收藏 0

精选30+云产品,助力企业轻松上云!>>>

前言:

​ DHCP Relay(DHCPR)DHCP中继(也叫做DHCP中继代理)是一个小程序,其可以实现在不同子网和物理网段之间处理和转发dhcp信息的功能。

​ 如果DHCP客户机与DHCP服务器在同一个物理网段,则客户机可以正确地获得动态分配的ip地址。如果不在同一个物理网段,则需要DHCP Relay Agent(中继代理)

一、DHCP中继原理

1、DHCP中继应用场景
  • 通常在DHCP分配网段过多的情况下,网关路由器上配置DHCP服务,压力过大,
  • 一般我们用第二路由器,或则第二台DHCP服务器来分担业务
2、DHCP中继原理

① 当dhcp client 启动并进行dhcp 初始化时,它会在本地网络广播配置请求报文。

② 如果本地网络存在dhcp server,则可以直接进行dhcp 配置,不需要dhcp relay。

③ 如果本地网络没有dhcp server,则与本地网络相连的具有dhcprelay 功能的网络设备收到该广播报文后,将进行适当处理并转发给指定的其它网络上的dhcp server。

④ dhcp server 根据dhcp client 提供的信息进行相应的配置,并通过dhcp relay 将配置信息发送给dhcp client,完成对dhcp client 的动态配置。

实际上,从开始到最终完成配置,需要多个这样的交互过程。

1、实验括扑图

在这里插入图片描述

2、设备配置
2.1、交换机配置
sysname SW1                            ###  给交换机配置名称SW1
vlan batch 10 20                       ###  建立VLAN 10 20

interface Ethernet0/0/1                ###  给e0/0/1接口配置access
 port link-type access            
 port default vlan 10              

interface Ethernet0/0/2                ###  给e0/0/2接口配置access
 port link-type access          
 port default vlan 20         

interface Ethernet0/0/3                ###  给e0/0/3接口配置access
 port link-type access              
 port default vlan 10              

interface Ethernet0/0/4                ###  给e0/0/4接口配置access
 port link-type access                
 port default vlan 20                 
 
interface GigabitEthernet0/0/1         ###  给g0/0/1接口配置access
 port link-type trunk                   
 port trunk allow-pass vlan 10 20       

2.2、路由器R1配置
sysname AR1                            ###   给路由器配置名称AR1
dhcp enable

interface GigabitEthernet0/0/0         ###   给g0/0/0接口配置IP地址
 ip address 12.0.0.1 255.255.255.0 
  
interface GigabitEthernet0/0/1.10      ###   设置单臂路由
 dot1q termination vid 10
 ip address 192.168.10.1 255.255.255.0 ###   g0/0/1.10子接口的IP地址
 arp broadcast enable                  ###   和单臂路由一起,开启arp
 dhcp select relay                     ###   开启服务,找到14.0.0.2这个接口
 dhcp relay server-ip 14.0.0.2

interface GigabitEthernet0/0/1.20      ###   设置单臂路由
 dot1q termination vid 20              
 ip address 192.168.20.1 255.255.255.0 ###   g0/0/1.20子接口的IP地址
 arp broadcast enable                  ###   和单臂路由一起,开启arp
 dhcp select relay                     ###   开启服务,找到14.0.0.2这个接口
 dhcp relay server-ip 14.0.0.2
 
interface GigabitEthernet0/0/2         ###   配置g0/0/2接口IP地址
 ip address 14.0.0.1 255.255.255.0 

ip route-static 15.0.0.0 255.255.255.0 12.0.0.2  ###  配置到15.0.0.0静态路由
2.3、路由器R2配置
sysname AR2                            ###   给路由器配置名称AR2
dhcp enable

interface GigabitEthernet0/0/0         ###   配置g0/0/0接口IP地址
 ip address 12.0.0.2 255.255.255.0 

interface GigabitEthernet0/0/1         ###   配置g0/0/1接口IP地址
 ip address 15.0.0.1 255.255.255.0 
 dhcp select relay                     ###   开启服务,找到14.0.0.2这个接口
 dhcp relay server-ip 14.0.0.2
 
ip route-static 0.0.0.0 0.0.0.0 12.0.0.1         ###  默认路由

2.4、路由器R3配置
sysname AR3                            ###   给路由器配置名称AR3
dhcp enable

ip pool DHCP15                         ###   建立地址池
 gateway-list 15.0.0.1 
 network 15.0.0.0 mask 255.255.255.0 
 excluded-ip-address 15.0.0.100 15.0.0.254 
 dns-list 8.8.8.8 2.2.2.2 
 
ip pool DHCPv10                         ###   建立地址池
 gateway-list 192.168.10.1 
 network 192.168.10.0 mask 255.255.255.0 
 dns-list 8.8.8.8 2.2.2.2 
 
ip pool DHCPv20                         ###   建立地址池
 gateway-list 192.168.20.1 
 network 192.168.20.0 mask 255.255.255.0 
 dns-list 8.8.8.8 2.2.2.2 
 
interface GigabitEthernet0/0/0          ###   配置g0/0/0接口IP地址
 ip address 14.0.0.2 255.255.255.0 
 dhcp select global                     ###   自接口上声明去哪个地方找服务
 
ip route-static 0.0.0.0 0.0.0.0 14.0.0.1         ###  默认路由

2.5、五台PC配置

在这里插入图片描述

五台PC都设置一样的,点击DHCP(自动获取IP地址),然后点击应用。

三、进行试验验证

1、获取地址

ipconfig /renew 查看DHCP 给你动态分配的地址

在这里插入图片描述

2、验证互通

在这里插入图片描述

3、可能出现的小问题

如果大家做完实验保存退出之后,下次在打开的话可能会出现无法获取IP地址,这个时候大家输入

ipconfig /release 这个命令是释放之前获取的IP地址
然后在重新输入 ipconfig /renew 就可以获取到IP地址了

上一篇: 虚树
o
粉丝 0
博文 58
码字总数 0
作品 0
私信 提问
加载中
请先登录后再评论。
华为交换机——DHCP中继实验。超详细,0基础都能看得懂!

文章目录 前言: DHCP Relay(DHCPR)DHCP中继(也叫做DHCP中继代理)是一个小程序,其可以实现在不同子网和物理网段之间处理和转发dhcp信息的功能。 如果DHCP客户机与DHCP服务器在同一个物理...

EAsonTX
06/30
0
0
DHCP服务器三种方法实现中继【dhcp叁】

前面两篇说明了dhcp的比较基础的东西,在实际工作中,想要简单的完成dhcp的配置并不是一件简简单单就能完成的事情,就比如说下面这种情况。 公司网络中有很多vlan,vlan之间是不能通讯的,每...

lining_at_HERE
2013/08/23
0
0
目录(V1.1)

欢迎IT爱好者关注微信公众号:小道讯息 Email:admin@iters.top 路由交换 Cisco三层交换机配置命令及解释 最简单的DHCP配置 路由器最简单的DHCP实验 RIP改static静态 华为交换机基础命令、配置...

小道讯息
2017/07/10
0
0
DHCP服务器三种方法实现中继【dhcp叁】

前面两篇说明了dhcp的比较基础的东西,在实际工作中,想要简单的完成dhcp的配置并不是一件简简单单就能完成的事情,就比如说下面这种情况。 公司网络中有很多vlan,vlan之间是不能通讯的,每...

lining_at_HERE
2013/08/23
0
0
目录(V1.2)@0823

Email:service@wuxier.cn 路由交换 Cisco三层交换机配置命令及解释 最简单的DHCP配置 路由器最简单的DHCP实验 RIP改static静态 华为交换机基础命令、配置 利用单臂路由实现VLAN间路由 华为e...

是阿杰啊
2017/07/10
0
0

没有更多内容

加载失败,请刷新页面

加载更多

测试工程师需要了解的shell变量知识

顾老师安全测试新课,报名地址: http://www.hbz100.com/pc/course/courseInfo.do?courseId=182320200226121405459。疫情期间,您在注意身体安全的同时,关注身体安全了吗?500元工作几天的薪...

啄木鸟顾老师
04/15
13
0
前端面试开源项目清单(github仓库,个人网站都有)

 复习前端面试的知识,是为了巩固前端的基础知识,最重要的还是平时的积累! ” 开源项目 https://github.com/InterviewMap/CS-Interview-Knowledge-Map 建立最好的面试地图。目前的内容包...

Fe-frank
05/11
12
0
【Flutter 专题】33 自定义 View 之 Canvas (一)

和尚最近在学习自定义 View,刚了解了一下 Paint 画笔的神奇之处,现在学习一下 Canvas 画布的神秘之处。Flutter 提供了众多的绘制方法,和尚接触不深,尽量都尝试一下。 Canvas 画布 drawCo...

阿策
2019/02/26
15
0
程序员,有需求做需求,有bug改bug,有什么好生气的呢?

对哦,我有什么好生气的呢! 本文分享自微信公众号 - WriteSimpleDemo(this_is_a_wechat)。 如有侵权,请联系 support@oschina.cn 删除。 本文参与“OSC源创计划”,欢迎正在阅读的你也加入...

PedroQin
2019/10/25
8
0
[从0到1搭建ABP微服务] - 搭建授权服务

一、简介 授权中心是微服务架构中最为核心重要的环节,不仅为web、app等客户端提供身份授权服务,还对其他微服务提供身份认证服务。ABP微服务架构中使用identityServer4框架进行身份管理,并...

osc_g91p39eg
29分钟前
14
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部