【微思网络】配置通过部署VRRP,实现主备设备共同分担用户业务案例

09/28 13:31
阅读数 14

配置通过部署 VRRP,实现主备设备共同分担用户业务案例

拓扑图:

【微思网络】配置通过部署VRRP,实现主备设备共同分担用户业务案例

规格

适用于所有版本、所有形态的 AR 路由器。

组网需求

如图 1 所示,作为 RouterA 和 RouterB 的 AR 路由器加入两个 VRRP 备份组以实现备份组中各设备既能相互备份,又能分担网络流量。

RouterA 作为备份组 1 的 Master,兼任备份组 2 的 Backup。

RouterB 作为备份组 2 的 Master,兼任备份组 1 的 Backup。

HostA 使用备份组 1 作网关,HostC 主机使用备份组 2 作为网关。

操作步骤

  1. RouterA 的配置

#

interface Ethernet1/0/0

ip address 192.168.1.1 255.255.255.0

#

interface Ethernet2/0/0

ip address 10.1.1.1 255.255.255.0 //连接 HostA 的接口的 IP 地址

vrrp vrid 1 virtual-ip 10.1.1.111 //配置备份组 1 的虚拟网关地址

vrrp vrid 1 priority 120 //配置 RouterA 在备份组 1 中的优先级为 120

vrrp vrid 2 virtual-ip 10.1.1.112 //配置备份组 2 的虚拟网关地址

#

ospf 1

area 0.0.0.0

network 192.168.1.0 0.0.0.255

network 10.1.1.0 0.0.0.255

#

2.RouterB 的配置

#

interface Ethernet1/0/0

ip address 192.168.2.1 255.255.255.0

#

interface Ethernet2/0/0

ip address 10.1.1.2 255.255.255.0 //连接 HostC 的接口的 IP 地址 vrrp vrid 1 virtual-ip 10.1.1.111 //配置备份组 1 的虚拟网关地址 vrrp vrid 2 virtual-ip 10.1.1.112 //配置备份组 2 的虚拟网关地址

vrrp vrid 2 priority 120 //配置 RouterB 在备份组 2 中的优先级为 120

#

ospf 1

area 0.0.0.0

network 192.168.2.0 0.0.0.255

network 10.1.1.0 0.0.0.255

#

3.RouterC 的配置

#

interface Ethernet1/0/0

ip address 192.168.1.2 255.255.255.0

#

interface Ethernet2/0/0

ip address 192.168.2.2 255.255.255.0

#

interface Ethernet3/0/0

ip address 20.1.1.1 255.255.255.0

#

ospf 1

area 0.0.0.0

network 192.168.1.0 0.0.0.255

network 192.168.2.0 0.0.0.255

network 20.1.1.0 0.0.0.255

#

4.验证配置结果

在 HostA 上对 HostB 进行 tracert 测试,可以看到 HostA 经过 RouterA 和 RouterC 到达 HostB。显示信息看如下:

<HostA> tracert 20.1.1.100
traceroute to 20.1.1.100(20.1.1.100), max hops: 30, packet length: 40
1 10.1.1.1 120ms 50 ms 60 ms
2 192.168.1.2 100 ms 60 ms 60 ms
3 20.1.1.100 130 ms 90 ms 90 ms



在 HostC 上对 HostB 进行 tracert 测试,可以看到 HostC 经过 RouterB 和 RouterC 到达 HostB。

显示信息看如下:
<HostC> tracert 20.1.1.100
traceroute to 20.1.1.100(20.1.1.100), max hops: 30, packet length: 40

1 10.1.1.2 30 ms 60 ms 40 ms
2 192.168.2.2 90 ms 60 ms 60 ms
3 20.1.1.100 70 ms 60 ms 90 ms

在 RouterA 上执行 display vrrp 命令,可以看到 RouterA 分别作为备份组 1 的 Master 和

备份组 2 的 Backup。其中备份组 1 的“state”为 Master,备份组 2 的“state”为 Backup。

<RouterA> display vrrp
Ethernet2/0/0 | Virtual Router 1
state : Master
Virtual IP : 10.1.1.111
Master IP : 10.1.1.1
PriorityRun : 120
PriorityConfig : 120
MasterPriority : 120
Preempt : YES Delay Time : 0 s
TimerRun : 1 s
TimerConfig : 1 s
Auth Type : NONE
Virtual Mac : 0000-5e00-0101
Check TTL : YES
Config type : normal-vrrp
Backup-forward : disabled
Create time : 2007-11-22 16:02:21
Last change time : 2007-11-22 16:02:25
Ethernet2/0/0 | Virtual Router 2
state : Backup
Virtual IP : 10.1.1.112
Master IP : 10.1.1.2
PriorityRun : 100
PriorityConfig : 100
MasterPriority : 100
Preempt : YES Delay Time : 0 s
























TimerRun : 1 s

TimerConfig : 1 s

Auth Type : NONE

Virtual Mac : 0000-5e00-0102

Check TTL : YES

Config type : normal-vrrp

Backup-forward : disabled

Create time : 2007-11-22 16:03:05

在 RouterB 的 Ethernet2/0/0 接口上执行 shutdown 命令,模拟备份组 2 的网关故障。在

RouterA 上执行 display vrrp 命令,可以看到 RouterA 分别作为备份组 1 的 Master 和备份组 2

的 Master。其中,备份组 1 和备份组 2 的“state”均为 Master。此时,两个 VRRP 备份组的虚拟网关都在 RouterA 上。

<RouterA> display vrrp Ethernet2/0/0 | Virtual Router 1

state : Master
Virtual IP : 10.1.1.111
Master IP : 10.1.1.1
PriorityRun : 120
PriorityConfig : 120
MasterPriority : 120
Preempt : YESDelay Time : 0 s
TimerRun : 1 s
TimerConfig : 1 s
Auth Type : NONE
Virtual Mac : 0000-5e00-0101
Check TTL : YES
Config type : normal-vrrp
Backup-forward : disabled
Create time : 2007-11-22 16:02:21
Last change time : 2007-11-22 16:02:25














Ethernet2/0/0 | Virtual Router 2

state : Master

Virtual IP : 10.1.1.112

Master IP : 10.1.1.1

PriorityRun : 100

PriorityConfig : 100

MasterPriority : 100

Preempt : YES Delay Time : 0 s

TimerRun : 1 s

TimerConfig : 1 s

Auth Type : NONE

Virtual Mac : 0000-5e00-0102

Check TTL : YES

Config type : normal-vrrp

Backup-forward : disabled

Create time : 2007-11-22 16:03:05

Last change time : 2007-11-22 16:03:09

微信咨询 微信公众号

【微思网络】配置通过部署VRRP,实现主备设备共同分担用户业务案例

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部