文档章节

实验:DHCP中继

o
 osc_kb5fqz4x
发布于 07/01 15:53
字数 718
阅读 20
收藏 0

精选30+云产品,助力企业轻松上云!>>>

DHCP中继实验拓扑图
在这里插入图片描述

一、实验要求:

一般小型网络使用DHCP都配置在拓扑图AR2路由上,但稍复杂一些的网络,服务器经常集中存放在服务器区, DHCP服务器和客户端不在同一个网段, DHCP的广播包被三层设备阻止,会导致DHCP获取地址失败。此时,可以在离客户端最近的三层设备接口上配置DHCP中继,让其进行辅助寻址,进行DHCP 请求广播包的转发。所以我们需要在AR1上配置DHCP中继服务。

二、实验设备

一台交换机、三台路由器、5台PC机。

三、 配置思路:

SW1交换机做access和trunk命令,AR1要配置DHCP中继命令和接口ip地址,AR2要配置请求到AR1的DHCP服务、单臂路由、子接口配置地址、接口ip地址,AR3也要配置请求到AR1的DHCP服务、接口ip地址。

四、 配置命令

################SW1################
system-view 

sysname sw1

vlan batch 10 20                         ##创建vlan 10  20

interface Ethernet0/0/1                      ##进接口
 port link-type access                              ##设置为access链路
 port default vlan 10                                        ##在接口里绑定vlan
 
interface Ethernet0/0/2
 port link-type access
 port default vlan 20

interface Ethernet0/0/3
 port link-type access
 port default vlan 10

interface Ethernet0/0/4
 port link-type access
 port default vlan 20

interface GigabitEthernet0/0/1         ##进接口
 port link-type trunk                           ##设置为trunk链路
 port trunk allow-pass vlan 10 20                         ##在接口里通过vlan 10 20流量
################ar1################
system-view 

sysname ar1

dhcp enable          ##启用dhcp服务

ip pool dhcp15.0.0.0
 gateway-list 15.0.0.1 
 network 15.0.0.0 mask 255.255.255.0 
 dns-list 8.8.8.8 2.2.2.2 
static-bind  ip-address 15.0.0.88 mac-address 5489-98C3-03AC   ##指定ip

quit

ip pool dhcpvlan10
 gateway-list 192.168.10.1 
 network 192.168.10.0 mask 255.255.255.0 
 dns-list 8.8.8.8 2.2.2.2 

quit

ip pool dhcpvlan20
 gateway-list 192.168.20.1 
 network 192.168.20.0 mask 255.255.255.0 
 dns-list 8.8.8.8 2.2.2.2 

quit

interface GigabitEthernet0/0/0
 ip address 14.0.0.2 255.255.255.0 
 dhcp select global               ##去全局 请求DHCP服务

quit
ip route-static 0.0.0.0 0.0.0.0 14.0.0.1

################ar2################
system-view 

sysname ar2

dhcp enable                         ##启用dhcp

interface GigabitEthernet0/0/0        ##进入接口
 ip address 12.0.0.1 255.255.255.0       ##设置接口ip地址

quit

interface GigabitEthernet0/0/1.10           ##进入子接口
 dot1q termination vid 10                      ##封装dot1q协议,该子接口对应vlan 10
 ip address 192.168.10.1 255.255.255.0            ##设置子接口ip地址
 arp broadcast enable
 dhcp select relay                                   ##基于DHCP中继
 dhcp relay server-ip 14.0.0.2                          ##去14.0.0.2请求DHCP服务

quit

interface GigabitEthernet0/0/1.20
 dot1q termination vid 20
 ip address 192.168.20.1 255.255.255.0 
 arp broadcast enable
 dhcp select relay
 dhcp relay server-ip 14.0.0.2

quit

interface GigabitEthernet0/0/2
 ip address 14.0.0.1 255.255.255.0 

ip route-static 15.0.0.0 255.255.255.0 12.0.0.2      ## 设置静态路由
################ar3################
system-view 

sysname ar3

dhcp enable

interface GigabitEthernet0/0/0
 ip address 12.0.0.2 255.255.255.0 

quit

interface GigabitEthernet0/0/1
 ip address 15.0.0.1 255.255.255.0 
 dhcp select relay
 dhcp relay server-ip 14.0.0.2

ip route-static 0.0.0.0 0.0.0.0 12.0.0.1   ##配置默认路由

PC端要开启dhcp服务
在这里插入图片描述

五、验证

使用ipconfig /renew命令在pc端查看dhcp分配的ip地址情况

PC5:
在这里插入图片描述
PC1:
在这里插入图片描述
PC2:
在这里插入图片描述
从这里看到都能正常获取DHCP分配的ip地址,我们再用ping命令查看一下连通性。





PC1 ping PC5:
在这里插入图片描述
PC1 ping PC2:
在这里插入图片描述


o
粉丝 0
博文 61
码字总数 0
作品 0
私信 提问
加载中
请先登录后再评论。
Cisco PT模拟实验(18) 路由器DHCP服务器及中继配置

Cisco PT模拟实验(18) 路由器DHCP服务器及中继配置 实验目的: 掌握路由器DHCP服务器的配置方法 掌握DHCP中继代理的配置方法 掌握DHCP协议及其中继的原理及实现过程 实验背景: 随着公司网络...

狄钦dQ
2017/09/13
0
0
DHCP(动态主机配置协议)实验:

注意:以下四个实验,均要注意防火墙和Selinux对服务的影响: 1.简单的DHCP服务搭建 实验环境:两台虚拟机,使用桥接模式 DHCP服务器端IP地址: 安装软件: 修改配置文件: 客户端验证:(...

Cinyann
2017/06/20
0
0
Windows server2008 DHCP中继代理

Windows server2008 DHCP 中继代理 DHCP中继代理作用: 在大型的网络中,可能会存在多个子网。DHCP客户机通过网络广播消息获得DHCP服务器的响应后得到IP地址。但广播消息是不能跨越子网的。因...

伤明明
2018/01/10
0
0
华为交换机——DHCP中继实验。超详细,0基础都能看得懂!

文章目录 前言: DHCP Relay(DHCPR)DHCP中继(也叫做DHCP中继代理)是一个小程序,其可以实现在不同子网和物理网段之间处理和转发dhcp信息的功能。 如果DHCP客户机与DHCP服务器在同一个物理...

osc_1m96ifq3
07/01
12
0
华为交换机——DHCP中继实验。超详细,0基础都能看得懂!

文章目录 前言: DHCP Relay(DHCPR)DHCP中继(也叫做DHCP中继代理)是一个小程序,其可以实现在不同子网和物理网段之间处理和转发dhcp信息的功能。 如果DHCP客户机与DHCP服务器在同一个物理...

EAsonTX
06/30
0
0

没有更多内容

加载失败,请刷新页面

加载更多

Kafka如何在千万级别时优化JVM GC问题?

大家都知道Kafka是一个高吞吐的消息队列,是大数据场景首选的消息队列,这种场景就意味着发送单位时间消息的量会特别的大,那既然如此巨大的数据量,kafka是如何支撑起如此庞大的数据量的分发...

hummerstudio
06/18
0
0
我打赌!90%程序员都破解不了这个粽子,不信你试!

放假了 各位读者朋友们,马上就是端午小长假啦,开心激动有木有? 新的故事文章还在创作中,写了初稿感觉不太满意又推倒重来。其实写故事还是挺难的,读者可能第一次第二次有新鲜感,写多了就...

轩辕之风
06/24
0
0
如何删库跑路?教你使用Binlog日志恢复误删的MySQL数据

前言 “删库跑路”是程序员经常谈起的话题,今天,我就要教大家如何删!库!跑!路! 开个玩笑,今天文章的主题是如何使用Mysql内置的Binlog日志对误删的数据进行恢复,读完本文,你能够了解...

后端技术漫谈
01/14
0
0
PHP设计模式之代理模式

PHP设计模式之代理模式 代理人这个职业在中国有另外一个称呼,房产经济人、保险经济人,其实这个职业在国外都是叫做房产代理或者保险代理。顾名思义,就是由他们来帮我们处理这些对我们大部分...

硬核项目经理
2019/09/23
0
0
Redis的复制模式

Redis的复制功能分为同步(sync)和命令传播(command propagate)两个操作。 同步 同步操作用于将从服务器的数据库状态更新至主服务器当前所处的数据库状态。 1. 旧版本的执行步骤 从服务器...

osc_s9cni3go
5分钟前
0
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部