vue+webpack添加对pug的支持

2018/12/12 14:16
阅读数 49
// 安装pug和加载器
yarn add pug-loader pug-plain-loader pug --dev

  

// webpack.config.js中 添加规则

{ test: /\.pug$/, use: ['pug-plain-loader'] }

 

使用 

 
<template lang="pug">
    div
</template>

<script>
export default {}
</script>

<style>
</style>

  

如果不装pug-plain-loader会报错:

Component template requires a root element, rather than just text.

  

 

参考:https://stackoverflow.com/questions/51073702/vue-pug-language-has-not-been-recognized-in-vue-template

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部