swagger生成错误问题 汇总解决

2019/12/09 11:41
阅读数 4.8K

Unable to render this definition

The provided definition does not specify a valid version field.

Please indicate a valid Swagger or OpenAPI version field. Supported version fields are swagger: "2.0" and those that match openapi: 3.0.n (for example, openapi: 3.0.0).

解决方法:

api中的Controller/Action 加入[HttpPost]或者 [HTTPGet]

传递参数模型存在问题.

 

 
 
 
展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部