Robot 安装

2019/04/06 11:07
阅读数 34

安装一个测试环境的

下载python27

升级pip

E:\Python27\python -m pip install --upgrade pip

安装robotramework

E:\Python27\Scripts\pip install -U wxpython

http://sourceforge.net/projects/wxpython/files/wxPython/2.8.12.1/

下载wxpython

 

--后来发现只能下载后安装,否则不起作用,是不是有些环境设置不正确?

并解压,在解压后的目录下执行

E:\Python27\python setup.py install

 Robot framework-selenium2library下载和安装

下载地址:https://github.com/robotframework/Selenium2Library#readme

 

E:\Python27\Scripts\pip install robotframework

E:\Python27\Scripts\pip install robotframework-ride

E:\Python27\Scripts\pip install robotframework-selenium2library

E:\Python27\Scripts\pip install robotframework-archivelibrary

E:\Python27\Scripts\pip install robotframework-SSHLibrary

E:\Python27\Scripts\pip install robotframework-ftplibrary

E:\Python27\Scripts\pip list

   

E:\Python27\python.exe ride.py

   

   

labrary中增加 Selenium2Library

   

   

   

command: pybot.bat --argumentfile g:\temp\RIDEuogjgg.d\argfile.txt --listener E:\Python27\lib\site-packages\robotide\contrib\testrunner\TestRunnerAgent.py:51517:False E:\Python27\Scripts\百度搜索

command: pybot.bat --argumentfile c:\users\admini~1\appdata\local\temp\RIDEcrbfif.d\argfile.txt --listener e:\python27\lib\site-packages\robotide\contrib\testrunner\TestRunnerAgent.py:49564:False E:\Python27\firsttest

[Error 2]

test finished 20180809 17:56:51

   

   

报错处理方法

   

注意:

1、python要添加到环境变量的path中

2、错误:command: pybot.bat --argumentfile c:\users\keikei\appdata\local\temp\RIDEama2ym.d\argfile.txt --listener D:\Python27\lib\site-packages\robotide\contrib\testrunner\TestRunnerAgent.py:52418 E:robot\测试项目

解决:将"C:\Python27\Scripts "添加到PATH环境变量中。命令提示符号查看,RF版本。提示pybot 不是内部命令,说明环境变量设置有问题。

   

   

报错处理方法

Error while finding spec for 'robot.run' (ImportError: No module named 'robot')

49564

   

   

   

建快捷方式 robot

e:\Python27\pythonw.exe -c "from robotide import main;main()"

   

   

   

   

20180809 21:57:21.634 [INFO]: Found Robot Framework version 3.1a1 from 'e:\Python27\lib\site-packages\robotframework-3.1a1-py2.7.egg\robot'.

   

20180809 21:57:21.634 [INFO]: Started RIDE 1.5.2.1 using python version 2.7.15 with wx version 2.8.12.1 in win32.

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部