文档章节

EIGRP 基础实验

o
 osc_a22drz29
发布于 2019/03/27 17:23
字数 977
阅读 16
收藏 0

行业解决方案、产品招募中!想赚钱就来传!>>>

一、环境准备

1. 软件:GNS3

2. 路由:c7200

二、实验操作

实验要求:

1、掌握EIGRP 的基本配置

2、掌握EIGRP 的通配符掩配置方法

3、掌握EIGRP 的自动汇总特性,理解EIGRP 的自动汇总的缺陷以及如何关闭自动汇总

4、掌握EIGRP 的手工汇总

5、掌握通过 ip default-network 命令配置 EIGRP 默认网络

6、掌握EIGRP 的手工汇总的方法

实验拓扑:

实验过程:

1、配置各台路由器的IP 地址,并且使用ping 命令确认各路由器的直连口的互通性。

  参照上一章(RIP实验)

2、在三台路由配置EIGRP 自治系统编号为33

参考命令:

R1配置:
R1(config)#router eigrp 33    
R1(config-router)#network 192.168.3.0 0.0.0.255
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#network 10.0.0.0
R2配置:
R2(config)#router eigrp 33    
R2(config-router)#network 192.168.4.0
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.1.0
R3配置:
R3(config)#router eigrp 33    
R3(config-router)#net 10.0.0.0
R3(config-router)#net 192.168.5.0
R3(config-router)#net 192.168.2.0

问题1、查看各路由器的路由表,在R1ping 10.33.4.1,能否ping通?

R1路由表:

R2路由表:

R3路由表:

答:在R1上ping 10.33.4.1,不能ping通。因为由于自动汇总,R1上没有到达10.33.4.1的路由条目。

3、在任意一台路由器上观察EIGRP 的邻居关系

参考命令:

R1#show ip eigrp neighbors

4、在任意一台路由器上查看路由器

参考命令:

R1#show ip route

5、在各路由器上查看EIGRP拓扑表

参考命令:

R#show ip eigrp topology

R1 拓扑表:

R2 拓扑表:

R3 拓扑表:

问题2:在拓扑表中包含几条记录?举例说明其中一条记录的AD和FD值,并写出其FD计算过程。

答:R1包含10条记录。

    R2包含4条记录。

    R3包含10条记录。

 

记录:R1 >>> 到达R2的192.168.2.0网络,FD:30720、AD:28160

 

FD 计算方式:网络入口最小带宽为100000Kbit,时延=100usec,metric=[10000000/100000+(100+100)/10]*256=30720

 

6、在各路由器上查看EIGRP接口

R#show ip eigrp interfaces

R1 EIGRP接口:

R2 EIGRP接口:

R3 EIGRP接口:

7、查看协议信息

参考命令:

R#show ip protocols

R1 协议信息:

R2 协议信息:

R3 协议信息:

8、关闭各路由器自动汇总,清空路由表

参考命令:

R1(config)#router eigrp 33

R1(config-router)#no auto-summary

R1#clear ip route *

此时查看每个路由器路由表,有什么变化

R1路由表:

R2路由表:

R3路由表:

问题3:如果此时在R1上ping 10.33.4.1能否ping通?

答:在R1上ping 10.33.4.1能ping通。因为关闭自动汇总之后,R1上有到达10.33.4.1的路由条目。

9、在路由器R1和R3上配置手动汇总

参考命令:

R1(config)#int f0/0

R1(config-if)#ip summary-address eigrp 33 10.33.0.0 255.255.252.0

R3(config)#int f0/1

R3(config-if)#ip summary-address eigrp 33 10.33.4.0 255.255.252.0

问题4:查看各路由器路由表,有什么不同

R1路由表:

R2路由表:

R3路由表:

答:各个路由器的路由表中添加了手动汇总的路由条目,解决了连续子网划分问题。

10、配置默认网络

在R3上配置静态路由

R3(config)#ip route 0.0.0.0 0.0.0.0 211.67.188.2

在R3上声明默认网络

R3(config)#router eigrp 33

R3(config-router)#network 211.67.188.0

R3(config)#ip default-network 211.67.188.0

问题5:在各路由器上查看路由表,看有什么变化?

R1路由表:

R2路由表:

R3路由表:

答:变化,各个路由器上有到达211.67.188.0网段的路由条目。

11、修改R1的f0/0接口的K值为k1=1,k2=1,k3=1,k4=0,k5=1

参考命令:

R1(config)#router eigrp 33

R1(config-router)# metric weights 0 1 1 1 0 1

问题6:修改后查看路由器R1和R2的邻居关系是否存在?这说明了什么?

答:路由器R1和R2的邻居关系不存在,因为邻居关系需要满足的条件之一是K值相同。

 

 

o
粉丝 0
博文 500
码字总数 0
作品 0
私信 提问
加载中
请先登录后再评论。
mvc框架--Razor

Razor 是一个轻巧而优雅的servlet mvc框架 # 又一个轮子? no,写就她是为了证实我个人的某些想法,并在这个过程中练练手,这两种冲动碰撞在一起,自然而然地产生了Razor # Razor的现在和未来...

dtubest
2013/01/25
2.9K
0
vss2svn2git

这个程序导入Visual SourceSafe(VSS)库到一个git存储库。 这是一个分叉来自vss2svn。再一次,我需要一些方法来从一个旧的VSS 6.0数据库中提取历史,而vss2git做这个事不正确。vss2svn预编译的...

匿名
2013/05/17
618
0
[译] WPF MVVM 循序渐进(从基础到高级)

本文翻译自Shivprasad koirala在CodeProject上的文章:[WPF MVVM step by step (Basics to Advance Level)][1] 简介 从我们还是儿童到学习成长为成年人, 生命一直都在演变。 对于软件架构, ...

不插电码农
2015/11/27
1.5K
1
open-vswitch: GRE隧道网络实验

1.宿主机配置网络: internel/data01 分别是管理网络/传输网络交换机 ; eth1 此处对应管理网络网卡 ens192 的 vlan为610的打过vlan的NIC设备; eth0 此处对应传输网络网卡 ens160 的 NIC设备....

guojy8993
2015/10/09
182
0
Python使用xslt提取网页数据

1,引言 在Python网络爬虫内容提取器一文我们详细讲解了核心部件:可插拔的内容提取器类gsExtractor。本文记录了确定gsExtractor的技术路线过程中所做的编程实验。这是第一部分,实验了用xsl...

fullerhua
2016/05/16
673
0

没有更多内容

加载失败,请刷新页面

加载更多

Linux拜拜!微软给WSL加入GPU支持,Windows终于迎来命令行包管理工具

点击蓝字“ 大白技术控 ”关注我哟 加个“星标★”,每日良时,好文必达! 白交 发自 凹非寺 量子位 报道 | 公众号 QbitAI 看完昨晚微软Build大会,虽然开发者不能亲自到现场,但看到WSL更新...

大白技术控
05/25
0
0
GraphQL

网文、分享汇总 干货分享 | GraphQL 数据聚合层 http://www.sohu.com/a/235978606_205771 awesome-graphql https://github.com/chentsulin/awesome-graphql 一些graphql相关的java项目 周边项......

素雷
11分钟前
4
0
如何在jQuery中选择具有多个类的元素? - How can I select an element with multiple classes in jQuery?

问题: I want to select all the elements that have the two classes a and b . 我想选择具有两个类a和b所有元素。 <element class="a b"> So, only the elements that have both classe......

javail
34分钟前
5
0
MySql查询所有字段不为空值的数据及Mybatis的#号和$符的区别引起的问题

1.MySql查询所有字段不为空值的数据 搜了一上午搜不到,最后用Mybatis的foreach标签,先查询出表字段, SELECT COLUMN_NAMEFROM INFORMATION_SCHEMA.ColumnsWHERE table_name='lltest'...

不忘初心牢记使命
34分钟前
32
0
五分钟搞定WebRTC视频录制

WebRTC中文社区是一个为大家解决在使用WebRTC当中遇到问题所建立的社区,欢迎更多学习和使用WebRTC的人加入进来,一起建设。 视频录制 在之前的文章里我们提到过视频录制的两种方式:客户端录...

死磕音视频
41分钟前
13
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部