RTX 3080 Linux和Windows 平台兼容性问题

10/18 07:20
阅读数 114

好不容易 在某电商平台抢到了一块3080显卡,高高兴兴的装机准备大搞游戏开始深度学习,却遇到了很多麻烦,当然经过多方探索,终于也是解决了linux和Windows双平台的兼容性问题,目前Pytorch和TensorFlow都能使用。

首先是linux平台

最快方法:去NVIDIA官网下载cuda11.1,从这个版本才开始支持30系列显卡。同时记得把cudnn也顺便下载了。cuda11.1自带显卡驱动,所以显卡驱动无需单独安装,提前装了也没事。

深坑:Linux不同的发行版的桌面可能对30系显卡存在兼容问题,请尝试多个linux桌面,我是在unity下才能打开桌面,Ubuntu自带的Gnome(好像是这个?)不能进入。至于怎么在无法进入桌面情况下安装unity,请在命令台ALT+CTRL+F3等命令,我不太清楚每个F键的区别,多多尝试。

然后是Windows平台,这个简单很多,cuda11.1和cudnn都从Nv官网下载,一路装到底也不会进不了桌面。

但是,装好cuda和cudnn以及显卡驱动还只能算是入门关....

真正难的来了,GPU和cuda和框架如TF和torch等兼容性,目前我的经验是:

1.首选tf-nightly,pytorch-nightly等最新版本,这些都是cuda11.0环境编译的,和cuda11.1兼容性极好。(狂喜)

2.但是,很多项目,都使用的老版本的框架,这时候,tf选15.2的TF-GPU版本,实测兼容cuda11.1(测试项目deepfacelab,可以运行基本操作不报错,复杂操作暂时没测试)

3.pytorch目前只是测试在pytorch-nightly下可以运行,运行了GPUbenchmark,根据测得的数据来看,3080性能,半精度低于2080ti 20%,单精度超2080ti 50%,双精度更是好几倍2080ti的性能。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部