执行 cobbler get-loaders报错

2019/03/31 20:39
阅读数 48

 

在配置cobbler安装时执行 cobbler get-loaders报错

 

  1. [root@110:~]# cobbler get-loaders  
  2. Traceback (most recent call last):  
  3.   File "/usr/lib/python2.7/site-packages/cobbler/utils.py", line 2100, in local_get_cobbler_api_url  
  4.     data = yaml.safe_load(fh.read())  
  5.   File "/usr/lib64/python2.7/site-packages/yaml/__init__.py", line 93, in safe_load  
  6.     return load(stream, SafeLoader)  
  7.   File "/usr/lib64/python2.7/site-packages/yaml/__init__.py", line 71, in load  
  8.     return loader.get_single_data()  
  9.   File "/usr/lib64/python2.7/site-packages/yaml/constructor.py", line 37, in get_single_data  
  10.     node = self.get_single_node()  
  11.   File "/usr/lib64/python2.7/site-packages/yaml/composer.py", line 36, in get_single_node  
  12.     document = self.compose_document()  
  13.   File "/usr/lib64/python2.7/site-packages/yaml/composer.py", line 55, in compose_document  
  14.     node = self.compose_node(None, None)  
  15.   File "/usr/lib64/python2.7/site-packages/yaml/composer.py", line 84, in compose_node  
  16.     node = self.compose_mapping_node(anchor)  
  17.   File "/usr/lib64/python2.7/site-packages/yaml/composer.py", line 127, in compose_mapping_node  
  18.     while not self.check_event(MappingEndEvent):  
  19.   File "/usr/lib64/python2.7/site-packages/yaml/parser.py", line 98, in check_event  
  20.     self.current_event = self.state()  
  21.   File "/usr/lib64/python2.7/site-packages/yaml/parser.py", line 428, in parse_block_mapping_key  
  22.     if self.check_token(KeyToken):  
  23.   File "/usr/lib64/python2.7/site-packages/yaml/scanner.py", line 115, in check_token  
  24.     while self.need_more_tokens():  
  25.   File "/usr/lib64/python2.7/site-packages/yaml/scanner.py", line 149, in need_more_tokens  
  26.     self.stale_possible_simple_keys()  
  27.   File "/usr/lib64/python2.7/site-packages/yaml/scanner.py", line 289, in stale_possible_simple_keys  
  28.     "could not found expected ':'", self.get_mark())  
  29. ScannerError: while scanning a simple key  
  30.   in "<string>", line 384, column 1:  
  31.     server:192.168.0.110  
  32.     ^  
  33. could not found expected ':'  
  34.   in "<string>", line 386, column 1:  
  35.     # If set to 1, all commands will ...  
  36.     ^  
  37. Traceback (most recent call last):  
  38.   File "/usr/bin/cobbler", line 36, in <module>  
  39.     sys.exit(app.main())  
  40.   File "/usr/lib/python2.7/site-packages/cobbler/cli.py", line 660, in main  
  41.     cli = BootCLI()  
  42.   File "/usr/lib/python2.7/site-packages/cobbler/cli.py", line 187, in __init__  
  43.     self.url_cobbler_api = utils.local_get_cobbler_api_url()  
  44.   File "/usr/lib/python2.7/site-packages/cobbler/utils.py", line 2104, in local_get_cobbler_api_url  
  45.     raise CX("/etc/cobbler/settings is not a valid YAML file")  
  46. cobbler.cexceptions.CX: '/etc/cobbler/settings is not a valid YAML file'  

然后百度按照网友的方法操作还是不行

service cobblerd restart
cobbler get-loaders

后来检查/etc/cobbler/settings刚才配置的几个地方,发现有一个IP少了一个空格

修改后然后重启http和cobbler服务后,再cobbler get-loaders正常

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部