解决druid在OpenJDK11+Gradle中的依赖问题

原创
05/08 20:02
阅读数 171

1 问题描述

环境OpenJDK 11+Gradle,直接在build.gradle中引入druid的依赖,报错如下:

'dependencies.dependency.systemPath' for com.sun:tools:jar must specify an absolute path but is ${project.basedir}/lib/openjdk-1.8-tools.jar in com.alibaba:druid:1.2.6
'dependencies.dependency.systemPath' for com.sun:jconsole:jar must specify an absolute path but is ${project.basedir}/lib/openjdk-1.8-jconsole.jar in com.alibaba:druid:1.2.6

2 原因分析

具体原因的话在issue中可以知道,其实就是没有兼容JDK11

在这里插入图片描述

既然运行没有问题,那么就手动解决编译问题好了。

3 问题解决

根据IDEA的错误提示(具体因druid版本而异):

~/.gradle/caches/modules-2/files-2.1/com.alibaba/druid/1.2.6/c57198d77a31adf5bd36d35f9b12dc936b732587/druid-1.2.6.pom

修改提示中的pom文件:

在这里插入图片描述

把上面的两个包注释掉就可以了,在1.2.6版本的druid中,修改pom文件的第703行,添加注释即可:

在这里插入图片描述

再次重新导入依赖可以看到没有问题了:

在这里插入图片描述

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部