解决AUR无法正常升级WebStorm2021.1.1的问题

原创
05/08 15:22
阅读数 10

1 问题描述

环境Manjaro+paru,升级WebStorm的时候,错误提示如下:

在这里插入图片描述

2 原因

这个问题在ArchAUR官网上有讨论

在这里插入图片描述

就是PKGBUILD的文件中的版本号出错了,把版本号修改回来就可以了。

3 解决方案

上面说了解决方案就是找到WebStormPKGBUILD版本并进行修改,PKGBUILD根据包管理工具的不同位于不同的缓存文件夹下,这里列举两个常见的AUR助手的缓存位置:

  • yay~/.cache/yay
  • paru~/.cache/paru

笔者使用的是paru,进入~/.cache/paru/webstorm,修改PKGBUILD,把版本从错误提示信息的211.7142.468改为211.7142.46

在这里插入图片描述

在这里插入图片描述

修改完后重新安装:

paru -S webstorm

这样就成功了:

在这里插入图片描述

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部