【使用指南】用pip安装paddlepaddle

原创
2018/01/29 19:08
阅读数 125

导语

本周将整理汇总paddlepaddle的安装编译方法,发布系列推文。推文目录如下:


周一:用pip安装paddlepaddle

周二:用Docker安装运行paddlepaddle

周三:用Docker编译和测试PaddlePaddle

周四:从源码编译paddlepaddle

周五:基本使用概念和安装及编译问题汇总


欢迎大家在留言区分享您在相应环节中遇到的问题,我们会 一 一为您解答,同时也会选择一部分展示在周五汇总贴中;欢迎大家在留言区提出您的反馈,表达您的见解;本周每篇推文点赞数最多的一条留言会被置顶(当日推文统计时间截止次日中午12点)并赠送小礼品一份(paddlepaddle定制帽衫)


编写|shanyi

排版|wangp


PaddlePaddle可以使用常用的Python包管理工具 pip 完成安装,并可以在大多数主流的Linux操作系统以及MacOS上执行


 1 

使用pip安装

执行下面的命令即可在当前机器上安装PaddlePaddle的运行时环境,并自动下载安装依赖软件,版本为cpu_avx_openblas

pip install paddlepaddle

如果需要安装支持GPU的版本(cuda7.5_cudnn5_avx_openblas),需要执行:

pip install paddlepaddle-gpu


如果需要获取并安装最新的(开发分支)PaddlePaddle,可以从我们的CI系统中下载最新的whl安装包和c-api开发包并安装, 您可以点击阅读原文,从文中表格链接中找到需要的版本:

640?wx_fmt=png 640?wx_fmt=png

如果在点击链接时出现如图登陆界面,

点击“Log in as guest”即可开始下载


 2 

运行环境依赖

PaddlePaddle安装包由于不仅仅包含.py程序,而且包含了C++编写的部分,所以我们确保发布的二进制包可以支持主流的Linux操作系统,比如CentOS 6以上,Ubuntu 14.04以上,MacOS 10.12以上


PaddlePaddle发布的安装包会尽量对齐 manylinux1 标准(查看链接:https://www.python.org/dev/peps/pep-0513/#the-manylinux1-policy),通常使用CentOS 5作为编译环境。但由于CUDA库通常需要CentOS 6以上,而且CentOS 5即将停止维护,所以我们默认使用CentOS 6作为标准编译环境。

640?wx_fmt=png


640?wx_fmt=png

PaddlePaddle环境依赖


 3 

安装常见问题和解决方法

paddlepaddle*.whl is not a supported wheel on this platform.


出现这个问题的主要原因是,没有找到和当前系统匹配的paddlepaddle安装包。请检查Python版本是否为2.7系列。另外最新的pip官方源中的安装包默认是manylinux1标准,需要使用最新的pip (>9.0.0) 才可以安装。可以使用下面的命令更新您的pip:

pip install --upgrade pip

如果仍然存在问题,可以执行:

python -c "import pip; print(pip.pep425tags.get_supported())"

获取当前系统支持的安装包格式,并检查和需安装的包是否匹配。pypi安装包可以在该链接中找到(https://pypi.python.org/pypi/paddlepaddle/0.10.5)


如果系统支持的是 linux_x86_64 而安装包是 manylinux1_x86_64 ,需要升级pip版本到最新; 如果系统支持 manylinux1_x86_64 而安装包(本地)是 linux_x86_64 ,可以重命名这个whl包为 manylinux1_x86_64 再安装。


640?wx_fmt=png


*原创贴,版权所有,未经许可,禁止转载

*值班小paddle:wangp

*欢迎在留言区分享您的观点

640?wx_fmt=png

640?wx_fmt=gif

本文分享 CSDN - 飞桨PaddlePaddle。
如有侵权,请联系 support@oschina.cn 删除。
本文参与“OSC源创计划”,欢迎正在阅读的你也加入,一起分享。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部