看了本文让你laravel安装laravel-queue-rabbitmq一路顺风

03/26 12:25
阅读数 20

查找了无数的资料使用laravel如何安装laravel-queue-rabbitmq,出来的文章都是一样的,但是就是安装不了。经过数小时后,终于弄出来了,此教程送给正在安装的你。

本文实现环境

  • laravel5.8
  • centos7.3

一、问题复现

使用laravel安装laravel-queue-rabbitmq。

错误发生的是多么的无敌。

执行的命令是composer require vladimir-yuldashev/laravel-queue-rabbitmq
在这里插入图片描述
然后就开始了不停的搜索资料,我搜啊搜,一首歌没了,俩首歌没了,三首歌没了,搜索出来的回答基本都是一样的,就是使用上边的那个命令。

二、解决过程

我就很纳闷为什么那么多人 都可以实现到我这里就卡住了。

报错还分人?于是在一个回复里边看到了这样的回答

在这里插入图片描述
于是打开github地址去瞅瞅,这几个数字是直接映入眼帘啊!但是当时的我就当没看见,这是什么鬼东西。
在这里插入图片描述
直到解决完问题才明白这个图的意义所在

这个图第一列是包的版本,不出意外地话直接使用composer require vladimir-yuldashev/laravel-queue-rabbitmq安装的版本是10,也就是需要你的laravel的版本是6或者7.

由于laravel6和7需要的PHP版本太高了,就没有去使用。

找到了问题所在,就试试安装对应对应版本试试呗!composer require vladimir-yuldashev/laravel-queue-rabbitmq:7.2

但是依然不如意,这又是什么鬼
在这里插入图片描述
遇到这个问题不要慌,也就是提示“提示内存不足”,我们可以通过创建swap分区解决这个问题。

执行以下三条指令

dd if=/dev/zero of=/var/swap.1 bs=1M count=1024
mkswap /var/swap.1
swapon /var/swap.1

然后在执行composer require vladimir-yuldashev/laravel-queue-rabbitmq:7.2

很是完美,很是ok,一个问题就是这样解决的。
在这里插入图片描述

三、总结

其实这个问题在大佬哪里估计就不是什么问题,但是新手确实是有点难度的。

这个问题终究是对安装包不够熟悉,不了解laravel安装包时对版本的区别。

不管是laravle,以后碰到这类的问题,都需要详细查看文档,看看是不是版本不兼容了。

展开阅读全文
打赏
0
0 收藏
分享
加载中
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部