关于weblogic11g更换jdk的问题

原创
2018/01/05 15:29
阅读数 822

这边的weblogic默认的jdk的版本是jdk1.6,服务器上jdk1.6和1.7都安装的有。然后开发用的jdk的版本是1.7。虽然也很老,但是没办法,现在我们开发用的确实是jdk1.7。在这样的环境下,我们如何找到对weblogic的默认jdk进行更换呢。 通过百度和自己的动手尝试,然后具体的操作步骤如下:

  1. 登录服务器账户,然后命令行输入
rpm -qa|grep jdk

这样服务器安装的所有jdk都可以看见了。

java-1.7-openjdk-devel-1.7.0.65-2.5.1.2.e16_5.x86_64

2、然后找到jdk1.7的安装路径,复制上面找到的jdk的名称

rpm -ql java-1.7-openjdk-devel-1.7.0.65-2.5.1.2.e16_5.x86_64

3、找到最后文件夹名字为bin的就是jdk1.7的安装路径

/usr/lib/jvm/java-1.7-openjdk-devel-1.7.0.65-2.5.1.2.e16_5.x86_64/bin

4、打开weblogic的安装目录,找到startWebLogic.sh 在界面里有这样一行代码:

${JAVA_HOME}/bin/java/ ${JAVA_VM} -version

5、在这行代码之前重新定义JAVA_HOME的路径

export JAVA_HOME=/usr/lib/jvm/java-1.7-openjdk-devel-1.7.0.65-2.5.1.2.e16_5.x86_64/bin

6、然后重启weblogic,就会发现weblogic的jdk版本变成了1.7.然后在控制台添加jdk1.7编译的项目也正常了。不然1.7编译的,放到服务器上会报错。

展开阅读全文
打赏
1
1 收藏
分享
加载中
更多评论
打赏
0 评论
1 收藏
1
分享
返回顶部
顶部