文档章节

composer安装

echojson
 echojson
发布于 01/18 20:10
字数 1667
阅读 16
收藏 0

前言:随着开源的东西越来越多,一些好的代码我们是可以直接拿过来用的,github更是加快了这一节奏,在github上我们可以看到一些开源的项目、代码块、函数库、类结构等,我们可以直接Fork,然后用在我们自己的项目中,既高效又方便。nodejs 出现后,更是一大批开源的好东西被我们使用,npm就是node.js中蛮好用的包管理软件,我们可以用npm 命令复制其他人的一些好的项目,用起来很爽。但是,php中貌似还没有这样类似的包管理工具,我们发现别人的代码,还是停留在手工阶段,手工将其他人的代码copy到自己的项目中,有更新我们同样靠手工copy文件。于是composer应运而生了。

1、composer是什么?

前言说了。composer是PHP的包管理、包依赖关系管理工具,有了它,我们就很轻松一个命令就可以把他人优秀的代码用到我们的项目中来,而且很容易管理依赖关系,更新删除等操作也很轻易的实现。

2、 composer 的安装

composer是一款软件,当然也需要安装。它支持多平台,我们将在window和centos 上安装它。

2.1 wondows 安装

首先官网下载:https://getcomposer.org/Composer-Setup.exe 。很小。1M都没有。这个链接永远是最新版本的。下载好了后。就是各种下一步下一步安装了,到这一步,需要填入php.ini的所在目录,记住wamp这类的安装包会有2个php.ini文件。不要填apache的目录所在php.ini。需要填入php目录下的这个配置文件。

这样安装完成了。很爽。

2.2 安装的时候可能会出现以下出错:

  1. The openssl extension is missing, which will reduce the security and stability of Composer. If possible you should enable it or recompile php with --with-openssl"

意思是说php没有开启openssl配置。我们打开php目录下的php.ini。将openssl前面的分号去掉就可以了:

  1. 提示php的版本太低,composer支持5.3+的版本。如果你是5.3-的话就只能去升级一下php的版本了。

    接下来我们验证一下安装成功了没?打开cmd。win+r 快捷键打开cmd命令对话框,输入composer:

    说明安装成功了。恭喜。
    windows的版本安装,相对于比较简单很方便,其实呢,它替我们做了很多事。
    1、 帮我们把php和composer这两个命令给加到了系统环境变量。这样我们能全局只直接使用这两个命令:
    我们在安装的时候可以看到:

我们打开系统的环境变量看看,是否添加了:

2、帮我们把php composer.phar命令简化成composer命令了。很爽:

2.3 linux上的安装

linux上的安装其实说简单也跟简单,官网上有很多种安装方式,我们知道第一种就可以了,也是最快的。

 curl -s http://getcomposer.org/installer | php

2.4 错误提示

1、 如果出现-bash: php: command not found 错误提示,说明php是源码安装的,php这个命令没有加入到系统环境。我们在上一步安装windows版本的时候,软件已经帮自动我们帮把php命令加入了系统环境path路径。
linux下如何把php加入系统环境呢:

 01.修改/etc/profile文件使其永久性生效,并对所有系统用户生效,在文件末尾加上如下两行代码  
 02.PATH=$PATH:/usr/local/php5/bin  
 03.export PATH  

最后:执行 命令source /etc/profile或 执行点命令 ./profile使其修改生效,执行完可通过echo $PATH命令查看是否添加成功。
2、 如果提示:

#!/usr/bin/env php
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:
The openssl extension is missing, which means that secure HTTPS transfers are impossible.
If possible you should enable it or recompile php with --with-openssl

也是一样,php的openssl没有安装,需要进入php源代码重新编译,我这里简单记录下如何添加php的openssl扩展:
1、因为我是源码方式安装的php,所以需要重新编译,这点比windows上蛋疼的多。进入php的源码包,如果删除了的,需要重新下载这个对应的版本:

01.[root@localhost ~]# cd /lamp/php-5.4.11/ext/openssl/  
02.[root@localhost openssl]# 

2、 用phpize添加配置编译:

01.#openssl目录下有个config.w32和config0.m4,把config0.m4改名为config.m4(不清楚什么原因,必须这么改,很重要!!!)  
02.[root@localhost openssl]# cp config0.m4 config.m4  
03.[root@localhost openssl]# /usr/local/php/bin/phpize #使用phpize命令动态添加配置  
04.[root@localhost openssl]# ./configure --with-openssl --with-php-config=/usr/local/php/bin/php-config #编译  
05.[root@localhost openssl]# make  
06.[root@localhost openssl]# make test  
07.[root@localhost openssl]# make install  
08.Installing shared extensions:     /usr/local/php/lib/php/extensions/no-debug-zts-20100525/  

注意:如果configure这一步出错:configure: error: libssl not found!。可能是系统没安装openssl扩展,可以:yum -y install openssl-devel 安装。
3、 修改php.ini ,把刚才编译好的openssl.so添加进去:

01.[root@localhost no-debug-zts-20100525]# vi /usr/local/php/etc/php.ini   
02.#GG 定位到最小面,加入这一行:  
03.extension=openssl.so  

搞定,由于我们使用php,并没有用到apache。所以可以不用重启apache服务器。
安装好了后,我们验证下是否正确安装:

$ php composer.phar #执行  

3、 composer的使用

我们在正确成功安装好composer之后,就可以使用这个利器了。不管是windows版本还是linux版本使用命令方式都一样:

01.php composer.phar + 命令 

我们刚才安装的windows版本直接可以使用composer 命令,前面说了,其实也是php composer.phar这2个的组合。

新的问题出来了。就是我们每次要去新下载一个其他人的项目,我们都必须要到在新项目的目录下重新下载一次composer.phar文件或者是这样:[root@root /]# php /home/test/composer.phar 相对路径读取到composer。能不能也把composer.phar像php命令这样搞成一个全局的。直接用 composer该多好啊!

[root@localhost /]# cd /usr/local/composer/  
[root@localhost composer]# cp composer.phar /usr/bin/composer  

搞定,这样就能和windows一样,全局使用composer命令了。

© 著作权归作者所有

共有 人打赏支持
echojson
粉丝 0
博文 66
码字总数 129795
作品 0
深圳
私信 提问
composer的安装以及laravel项目的生成

composer 安装laravel composer 是PHP的依赖管理工具,需要PHP版本高于5.3且支持openssl。安装非常简单,执行下列命令 执行结果如下 讲执行文件移动到/usr/local/bin目录 显示版本号则可以正...

hey_heihei
2016/12/16
49
0
yii2 - composer 方式安装 / 管理扩展

composer 简单梳理 composer 作为 php 的依赖管理用起来还是很方便的,国内现在也有即时同步的镜像,所以不用爬墙也能很好的体验了 github 放着软件包 packagist 原数据,索引表 https://pa...

big_cat
2016/05/17
367
0
YII composer全局安装

php版本需要大于php5.4 需要开启php openssl扩展 找到php安装源码包中的ext目录下面的openssl目录 make && make install 全局安装 你可以将此文件放在任何地方。如果你把它放在系统的 目录中...

蜗牛奔跑
2015/08/20
0
0
使用 Composer 安装 Laravel 框架

前言: 1. Composer 安装 Laravel 有两种方式: 第一种是通过 Composer 的 create-project 命令安装 Laravel 框架,第二种是先通过 Composer 安装 Laravel 安装器,然后通过安装器安装 Lara...

天秤vs永恒
2016/08/22
21
0
Composer -- PHP依赖管理的新时代

Composer -- PHP依赖管理的新时代对于现代语言而言,包管理器基本上是标配。Java 有 Maven,Python 有 pip,Ruby 有 gem,Nodejs 有 npm。PHP 的则是 PEAR,不过 PEAR 坑不少: 依赖处理容易...

张悟空
2016/05/31
38
0

没有更多内容

加载失败,请刷新页面

加载更多

RabbitMQ入门

RabbitMQ是一个由erlang开发的基于AMQP(Advanced Message Queue)协议的开源实现。用于在分布式系统中存储转发消息,在易用性、扩展性、高可用性等方面都非常的优秀。是当前最主流的消息中间...

watermelon11
今天
15
0
今天的学习

自动加载:方法一 function __autoload( $className ){在这里,完成加载B这个类文件的工作。}class A{} //这是一个类$a1 = new A(); //这里没有自动加载的发生,因为A这个类...

墨冥
今天
2
0
印刷工艺步骤

印刷厂从收到订单到交付整个流程,一般涉及到以下步骤 1.设计(经过软件如cdr,psd,ai等等设计需要印刷的名片,宣传单,画册等物料); 2.排版拼版(在电脑软件这区域完成); 3.出版、出硫...

focusone
昨天
4
0
virtualbox中安装ubuntu

virtualbox+ubuntu 安装virtualbox,当前版本是6.0.4 下载ubuntu安装盘,建议lubuntu,链接是http://mirrors.ustc.edu.cn/ubuntu-cdimage/lubuntu/releases/18.04.2/release/lubuntu-18.04.......

chuqq
昨天
5
0
exists 谓词的子查询

https://blog.csdn.net/qq_19782019/article/details/78730882

仟昭
昨天
4
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部