Maven下载项目依赖jar包和使用方法

原创
2017/07/18 15:48
阅读数 44

一、Maven3.5.0安装与配置+Eclipse应用

参考:Maven3.5.0安装与配置+Eclipse应用

二、http://mvnrepository.com/

此处以http://mvnrepository.com/artifact/org.apache.spark/spark-core_2.11/2.1.1作为例子:

复制这一段加入到pom.xml即可:

 
  1. <!-- https://mvnrepository.com/artifact/org.apache.spark/spark-core_2.11 -->
  2. <dependency>
  3. <groupId>org.apache.spark</groupId>
  4. <artifactId>spark-core_2.11</artifactId>
  5. <version>2.1.1</version>
  6. <scope>provided</scope>
  7. </dependency>

右键Maven-----》Update Project:

右键Run As ----》Maven install

Maven会把与spark-core_2.11-2.1.1.jar相关的依赖包也一起下载下来,很方便。

Maven下载项目依赖jar包和使用成功!!!

特别注意<scope>provided</scope>,只在编译的classpath中加载和使用,打包的时候不会包含在目标包中。

 

所以如果想把该依赖包也一起打包,那么应该改成<scope>runtime</scope>。

具体可以参考:MAVEN Scope使用

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部