已解决:jdk版本冲突,nested exception is java.lang.UnsupportedClassVersionError:JVMCFRE003

原创
2019/06/15 13:24
阅读数 340

日志报错

日志报错:nested exception is java.lang.UnsupportedClassVersionError:JVMCFRE003 主版本错误:类=com/***/***/***/,偏移量=6(unable to load class com.***.***.***)

分析问题

我在项目中导入了一个新的jar包,程序调用这个jar包的时候,报了这样的一个错误“nested exception is java.lang.UnsupportedClassVersionError:JVMCFRE003 主版本错误:类=com/***/***/***/,偏移量=6(unable to load class com.***.***.***)”,经过分析,这是由于jar编译的jdk版本与目前项目编译的jdk版本不一致导致的。

解决方案

根据日志提示,只需要用1.6的jdk重新编译jar包就ok了(我的项目用的是1.6的jdk)。

本文同步分享在 博客“_陈哈哈”(CSDN)。
如有侵权,请联系 support@oschina.cn 删除。
本文参与“OSC源创计划”,欢迎正在阅读的你也加入,一起分享。

展开阅读全文
打赏
0
0 收藏
分享
加载中
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部