文档章节

Windows系统 Eclipse安装 Anaconda Tensorflow

稀疏矩阵
 稀疏矩阵
发布于 2017/09/09 00:00
字数 682
阅读 98
收藏 1

       最近在Win7、Win10操作系统上分别搭建成功了Eclipse+Pydev+Anaconda+Tensorflow环境,中间遇到了不少困难,但是都一一解决了,所以很想跟大家分享一下,好了,废话不多讲了,Let us go!

Step 1 安装jdk、eclipse,因为这个比较基础,相信大部分人都不是问题,再次不做过多解释~~我这里安装的是eclipse 4.5.2、jdk1.8。

Step 2 安装Pydev,这个地方我踩到坑了,因为自己的Eclipse不是最新版本,但是安装的Pydev是最新版本,导致无法用,什么?为什么不装最新版的Eclipse,额~~恋旧,主要是恋旧~~其实是担心最新版的Eclipse自己不会用~~~好吧,不扯了,我告诉大家这个问题我是怎么解决的~~

      首先到Pydev、官网查询自己的Eclipse支持什么版本的Pydev,Pydev官网:http://www.pydev.org/history_pydev.html,

哈哈,查到了,我的eclipse 4.5支持Pydev5.2.0的Pydev,哦也~~
 

依次点Help--Install New software...

然后点Add~~经过我多方调研,下面为大家介绍几个下载Pydev的网址:

https://dl.bintray.com/fabioz/pydev/old/,只能下载到4.5.3版本以前的Pydev

http://pydev.org/updates/,只能下到最新版本的Pydev

https://dl.bintray.com/fabioz/pydev/5.2.0,可以下到我需要的版本,后面是Pydev的版本号,应该5.0以后到最新的Pydev都可以下到,我只是猜测,没有一一试过哦~~~

 

输入如上图的网址,记得把"Show only latest versions of avaliable software"的√去掉~~

然后就可以点ok--Next--Finish喽~~

Step3 到Anaconda官网:https://www.anaconda.com/download/,下载适合自己版本的Anaconda,

我选择的是Python3.6 、64位Anaconda~~,然后选择自己的安装路径安装Anaconda,然后~然后~然后你的电脑上就安装好了Anaconda了拜~~呵呵~~对了,记得把你的Anaconda安装路径添加到path下哦~~

Step 4 安装Tensorflow

打开Anaconda自带的"Anaconda Prompt"~~

然后依次输入下面命令~~

创建一个名为tensorflow的conda环境

激活conda环境

如果安装CPU版本的Tensorflow,输入下面命令:

如果安装GPU版本的Tensorflow,输入下面命令:

这样就成功安装了Tensorflow了,下面测试一下吧~~

依次输入下面命令~~

>>> import tensorflow as tf
>>> hello = tf.constant('Hello, TensorFlow!')
>>> sess = tf.Session()
>>> print(sess.run(hello))

如果输出

Hello, TensorFlow!

那就对了,嘎嘎~~~

Step 5 Eclipse配置Tensorflow

依次点Window--Preference--Pydev--Interpreters--Python Interpreter

点击New,输入下面内容

Interpreter Name和Interpreter Executable:   注意了,Interpreter Executable输入的路径需选择

%Anaconda-Path%\envs\tensorflow\下的python,然后就大功告成喽~~

Last,让我们测试一下吧~~

哦也,测试成功!!!天也不早了,就到这里了,祝大家好运~~

 

 

© 著作权归作者所有

共有 人打赏支持
稀疏矩阵
粉丝 2
博文 9
码字总数 2847
作品 0
用Anaconda安装TensorFlow

一说起现在比较火的机器学习、深度学习之类的,不得不说的一定有谷歌的TensorFlow框架。关于TensorFlow我就不多说了,因为我对这个东西也不太了解,这才是第一次开始学习。 那么今天要说的是...

过了即是客
2017/04/25
0
0
(通用)深度学习环境搭建:tensorflow安装教程及常见错误解决

区别于其他入门教程的“手把手式”,本文更强调“因”而非“果”。我之所以加上“通用”字样,是因为在你了解了这个开发环境之后,那些很low的错误你就不会犯了。 大家都知道深度学习涉及到大...

caiyongji
2017/10/24
0
0
Linux安装Anaconda和TensorFlow

引 众所周知Python常用的版本有2.x和3.x,常常会引起版本问题。由于我在Linux系统中已经安装有Python3.x和对应的TensorFlow,现在遇到需要跑在Python2.x下的TensorFlow工程时,就很麻烦,因此...

Cloudox_
09/26
0
0
TensorFlow——快速安装

TensorFlow:2015年Google开源的机器学习框架 1、Anoconda安装 (1)Window,MacOS,Linux都已支持Tensorflow。 (2)Window用户只能使用python3.5(64bit)。MacOS,Linux支持python2.7和python3...

飞天小橘子
04/19
0
0
安装tensorflow、pyspark等遇到的问题

出现这些问题,很多时候是因为,忘记了机器上有两个Python环境。 默认环境是py2,而自己的工作环境是py3。 比如Linux上默认有py2.7,自己又安装了py3.5。比如Windows上,安装了py2,也安装了...

datadev_sh
06/26
0
0

没有更多内容

加载失败,请刷新页面

加载更多

五类数据存储模型行、列、键值对、文档、图

1、行存储 定义:关系模型使用记录(行或者元组)进行存储,记录存储在表中,表由架构界定。表中的每个列都有名称和类型,表中的所有记录都要符合表的定义。SQL是专门的查询语言,提供相应的...

PeakFang-BOK
37分钟前
1
0
部署springcloud到docker中

1.在centos7中安装docker 2.打包eureka-server: 修改application.properties: 此处,eureka.instance.perfer-ip-address=true 表示实例地址为服务器的ip地址 使用maven命令打包: cmd进入项...

狼王黄师傅
52分钟前
1
0
赋能,打造不确定性敏捷团队

writeademo
52分钟前
1
0
Go interface{} to string

package mainimport "fmt"func main() {var a interface{}a = "dsadjaldaldad"var b stringb = a.(string) // 话说,用人话说的话,这叫什么操作?fmt.Println(a, b)}...

taadis
55分钟前
0
0
数据库防火墙

数据库防火墙顾名思义是一款数据(库)安全设备,从防火墙这个词可以看出,其主要作用是做来自于外部的危险隔离。换句话说,数据库防火墙应该在入侵在到达数据库之前将其阻断,至少需要在入侵...

突突突酱
今天
1
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部