安装glimpse
安装glimpse
咸鱼恩 发表于6个月前
安装glimpse
  • 发表于 6个月前
  • 阅读 5
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 技术升级10大核心产品年终让利>>>   

系统: Ubuntu 14.0.4

Python 2.7.6

1.按文档http://pythonhosted.org/glimpse/quick-start.html#installation 所提供命令安装:

pip install glimpse ipython matplotlib

显示报错信息

现在最新版的PIL为1.1.7。现在基本使用pillow,Pillow 是 PIL的对Python3支持的另外一个分支,当然他对Python2也兼容,由于PIL安装起来比较烦,而使用pip可以很轻松的安装Pillow。

系统中已装有pillow依旧报错,所以再装一遍PIL。

 

2 安装PIL (尝试了网上的建立软连接,pip直接安装等方式均失败后,采用最以下最通用的解压安装方式后成功)

    ① http://www.pythonware.com/products/pil/下载自己需要的PIL版本,这里下载了1.1.7

    ② 解压安装(以root身份进行)

        $ tar xvfz Imaging-1.1.7.tar.gz

        $ cd Imaging-1.1.7

        $ python setup.py install

    ③ 强烈建议接着敲一下命令,安装一些库,免得以后处理图像的时候提示错误

        sudo apt-get install libjpeg62-dev 

        sudo apt-get install zlib1g-dev

        sudo apt-get install libfreetype6-dev

        sudo apt-get install liblcms1-dev

 

3 重复步骤1,安装成功

   运行测试用例 import glimpse.experiment 产生报错信息

    

因为在glimpse项目中所涉及到的check_arrays在scikit-learn 0.16.0版本时就被check_array取代了,在0.18.0中这个已经没有了,所有要降低scikit-learn的版本,采用如下操作:

    sudo pip uninstall scikit-learn  #当前版本

    sudo pip install scikit-learn==0.14.1  #高于该版本的会报错

 

4 重复步骤3中的测试用例,无报错。(终于在尝试了各种包的版本之后没有报错信息了:))

标签: Glimpse Python
共有 人打赏支持
粉丝 2
博文 3
码字总数 2728
×
咸鱼恩
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: