尝试新的UI库 NG-ZORRO 首个问题
博客专区 > poping 的博客 > 博客详情
尝试新的UI库 NG-ZORRO 首个问题
poping 发表于6个月前
尝试新的UI库 NG-ZORRO 首个问题
  • 发表于 6个月前
  • 阅读 544
  • 收藏 0
  • 点赞 1
  • 评论 0

新睿云服务器60天免费使用,快来体验!>>>   

前几天 阿里旗下的UI库更新了!!!

也就是Ant Design在Angular下的实现!取名为ng-zorro。由此Ant Design又添一名大将(原有基于React实现的Ant Design),这无论是对angular4在中国企业级应用的稳固还是Ant Design的延伸都是一步非常重要的路。

    听起来这名字还不错的。反正我蛮喜欢的。

    ok,首先上来是对他的介绍,这里我就不写了,也不贴文章了,一会把官网po出来,刚开始无非

讲讲对Ant Design思想的实现,然后无缝接入angular4啊之类之类的。

    当然了,既然是对angular4的实现,那么就一定会遵循angular4 的一些特性或者风格

    1.TypeScript    2.跨平台特性     3.Rxjs的实现     4.angular4的编程风格

    上面那些就不多说了哈,大家多多看看官网就好了,那上面巴拉巴拉还是说的挺多的。

    首先说一下官网给出的文档。

1.中文的。对,这是一个非常好的消息,虽然我不排斥英文文档,但母语面前还是最亲切的吧。

2.组件实例。每个组件下,文档中都会给出多种用法的详细实例,这也是秉承了原来基于React实现下的Ant Design的风格。组件的属性和事件都会给出详细的说明。

    我也刚接触,剩下的东西大家需要自己上手体会啊。我就不多说了。。。

    剩下的呢我就要说一下遇到的问题

    angular最新版本与当前ng-zorro还是有些不兼容的,在完成官网的快速上手中就出现了问题,

直接报错了,编译不通过,这个是我始料未及的,连入门教程都通不过呢。。。。

确定自己自己环境项目没有问题后,也确定按照入门教程来做的。还是不通过

官方的github中给出了答案,这里贴出该issues,官方的回答并没有解释出根本为题处在哪,只是简单的说明了新版的angular的cdk是 2.0.0-beta.10 ,出现了不兼容的问题,如果想正常使用ng-zorro 请下载

2.0.0-beta.8版本,命令如下:

npm install @angular/cdk@2.0.0-beta.8

   回滚后版本没有问题,可以正常使用。剩下的就是看看文档上手了。我就不多多说了。毕竟我也是刚开始看,说的不好那多尴尬,我不要面子的啊。。

避免尴尬贴一篇文章,知乎上ng-zorro专栏为数不多的文章    我所认知的 ANT DESIGN

另外贴出来一个基于vs code实现的ng-zorro的代码提示器

老话说的好,背靠大树好乘凉嘛,ng-zorro在阿里团队的带领下肯定有更长远的发展,拭目以待吧

=============8月31日,新版本更新,sdk不兼容问题已解决===========

  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 0
博文 4
码字总数 2097
×
poping
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: